You are not logged in.

  • Login

Dear visitor, you are currently not logged in. Login or Register as a new user .


Wednesday, August 1st 2012, 9:46pm

Anyone know how to properly get SPDIF working between Kemper and RME UFX inside Totalmix FX???

This crap is really confusing, and I cant seem to figure it out. I have everything hooked up properly. Now I need to understand how to properly set up the Kemper as master, RME as slave, and properly route this combination inside totalmix fx so I can actually start using this setup with SPDIF finally. Please help someone!!!

Thanks, Chad


Wednesday, August 1st 2012, 9:54pm

The UFX manual will explain it well I think. I was wondering the same thing and saw that the UFX has some sort of smart technology that should recognize that the kemper needs to be master. I have yet to try it as my Kemper has not arrived.


Wednesday, August 1st 2012, 10:04pm

Its hard to understand this since its my first go at using these types of I/O. I always had no problems when going straight analog through the kemper into the UFX. I just want the reamping capabilities that SPDIF has to offer. I figure you guys around these parts could help me fine tune this thing. I have a converter box between the optical and coaxial I/O from the kemper to the UFX, and its properly hooked up. The way I started off was selecting the input button on the kemper and selecting the SPDIF input box. Then I go to the RME fireface settings and set the sample rate at 44100 HZ, and use the ADAT1 as my Clock Source which should be correct since I didnt select internal clock source from the RME. Then I go to the matrix view in totalmix FX and try every combination under the sun between ADAT1 and my AN1/2 (main monitors) but no luck, and I cant even see a signal in any of those channels back in the mixer. Im stumped.


Wednesday, August 1st 2012, 10:10pm

first of all connect the spdif out of the kemper with the spdif in of the UFX
then go to the settings dialog of the UFX-driver (that is where you also change the latency of the UFX and various other stuff)
select "spdif" as clock-source in the "clock-mode" section
now the rme-mixer should get a signal (without any clitches and clicks that would indicate a wrong clock)
open the rme-mixer:
you should see 3 rows of faders
the upper row is for the physical inputs
the middle row represents the software-inputs (were you route your signals from a DAW)
the bottom row represents the physical outputs of the UFX
so, you have to find the fader (if you don´t see faders but only meteres: there is a small arrow that opens the channel in all glory) for the SPDIF inputs in the upper row and route them to the physical outputs that go to your monitoring system
under the fader of the spdif-input there is a field that says something like "AN 1/2"
click on this field and you should get a popup where you can select where you want to route that input. select the output where your monitoring is and turn up the volume/fader and voilá
there you are
check that the fader on your outputchannel (bottom row) is also open!


Wednesday, August 1st 2012, 10:19pm

oh, just read your newer post:
there is a BIG misconception in your thinking!
the optical in is ADAT
that is something completly different than spdif!!!
different format, differend code,...
no chance that that works!
you need to make an adapter-cable from coax to XLR and connect that from the kemper spdif-out to the RME AES/EBU in
(page 43 of the rme manual)
don´t forget to change the spdif format to consumer in the rme-settings!

This post has been edited 1 times, last edit by "tenderboy" (Aug 1st 2012, 10:24pm)


Wednesday, August 1st 2012, 10:32pm

Page 42 says that ADAT2 In can also be used as SPDIF optical input. It also says that ADAT2 Out can also be used as SPDIF optical output.

Tylerhb had said this to me in a PM we had about this subject...

"About your setup... The RME UFX that you have is a very cool audio
interface. The only thing that is not optimal about is that the SPDIF
in/out are only available as optical interfaces (you can use the ADAT
in/out as SPDIF). But cab use cheap converters from optical to coaxial
(about 15€ each). Using a digital SPDIF connection with the KPA is
always preferable. If you plan to do reamping the benefits from a
digital connection become even more evident. You dont lose any signal
quality and you dont need any reamping box."

I bought this converter box which should do the trick to utilize the SPDIF capabilities of the ADAT2 I/O.

I have no idea why this isnt working properly however. I have PM'd Tylerhb and hopefully he can chime in and help out sometime soon, but I would love to figure it out before then.


Wednesday, August 1st 2012, 10:40pm

ok, didn´t know this (i don´t have the UFX, only a babyface and a fireface 400)
do you have a cd-plyer or anything that has an optical out?
test that to see if you get any signal through the optical cable and take a broken cable out of the equation


Wednesday, August 1st 2012, 10:49pm

checked the cables out and they are fine. I wish I could find an easy answer to this problem.


Wednesday, August 1st 2012, 10:50pm

in the post you wrote that you checked the spdif input in the kemper input section
so you want to reamp?


Wednesday, August 1st 2012, 10:52pm

Not right now, I just want to get the signal going through the interface/monitors. Shouldn't that box always be checked anyways, when SPDIF is the only connection between the Kemper and the interface?