Button of the Mission Engineering EP1

  • Hi,


    I bought a Mission Engineering EP1-KP-GN. I've connected it to the KPA and the pedal and stomp button work. But: I can't press the button by pressing the pedal down. It seems like there are a few millimeters missing. In the package there was a small additional white soft pad that I attached beneath the pedal. Now it is too easy to press the pedal, i.e. when flipping the pedal down the button is almost always pressed.


    is that normal?


    im used to a Cry Baby, that needs a certain amount of power to enable the switch.

  • I had the same problem and ended up switching out the button. For me it made all of the difference in the world. It ends up being the same switch type just with more pressure required and more of a positive engaging feel.

  • I just got mine yesterday. I have to press the toe pretty good to get it to engage. There is no tactile feel to the switch, or click, when engaged. Mine also makes a lot of noise when you shake it, or even operate it on the floor, like the button and the bottom plate are loose. Was mildly disappointed, but it does work well, despite these complaints.


    Any links to the replacement button?

    Kemper Powerhead w/remote
    Focusrite 18i8 (2nd Gen) - Windows 10 - Ableton Live - Yamaha HS-8's - DT770 80 ohms

  • No luck on part number on the switch itself, just branded as carling. Tried to find any old threads with part details, will keep looking.
    in essence it's a momentary switch that has a click feel like a normal latching switch would have.....

  • I should be able to find something with the mfg.'s name. If I can't live with the current switch, I'll look in to the carling switch.


    Thanks!

    Kemper Powerhead w/remote
    Focusrite 18i8 (2nd Gen) - Windows 10 - Ableton Live - Yamaha HS-8's - DT770 80 ohms

  • Just for the ones who will come here by google search. I had the same issue:

    1. One pad is hard to engage the switch
    2. Two pads made the engaging too easy

    I didn't wanted to change the switch, so my solution was placing a small silicon bumper (THIS) on the switch. Now it works perfectly, You just have to use the one tall enough to fit your needs.:)