Question regarding Hex-Editor edited profiles...

  • So, are there any profiles that were edited and should be avoided (should not be loaded into our KPA's)?
    Just asking so we can be clear on the warning-post by MF (Guitardroid).
    Is it a prob to to load such profiles into our KPA's? And if it is, how can we identify them?

  • this is a major "viral threat" for the KPA... :cursing: just edit the name of a profile and bring down all the KPAs that load this one. Kemper should make this safe... and in any case bring up an easy solution for user-friendly total restore of the KPA.


    be sure to make a backup before importing new files in the future then... ;)

  • this is a major "viral threat" for the KPA... :cursing: just edit the name of a profile and bring down all the KPAs that load this one. Kemper should make this safe... and in any case bring up an easy solution for user-friendly total restore of the KPA.


    be sure to make a backup before importing new files in the future then... ;)


    I think we need an official response for this!

  • Cool down, guys. I don't believe that those profiles are dangerous, I've download them, played with it a bit, didn't liked them (boxed) and delete them...and my unit still works....
    It's not a virus that is replicating itself and infecting other profiles. This guy has edited (probably to quicker change the names) some of the profiles and load them back in his unit, just corrupted files....bad luck but nothing to panic about, IMHO.


    Anyway a CRC check should be easy to implement.....

    "Music is enough for a lifetime, but a lifetime is not enough for music" Serghei Rachmaninoff


  • And if the links to the hex-edited profiles are still up, they should be deleted from this forum.

    Nobody has said that those profiles have been shared, all what I said is that this guy has shared only 2 profiles (IIRC), not that those profiles are the ones creating the issue

    "Music is enough for a lifetime, but a lifetime is not enough for music" Serghei Rachmaninoff


  • Actually I just think that this was a bad chance with rafport's KPA. I can't really imagine that a corrupted file will get loaded into the KPA and brick it... 8|

    MJT Strats / PRS Guitars / Many DIY Guitars -- Kemper Profiler Rack / Kemper Remote / InEar

  • The only profiles shared by Rafport were the Bogner Alchemist ones, IIRC...

    Unfortunately not. There where two more profiles from rafport.
    "AC4TV" and "4W On Fire!"


    I have deleted the Bogner and the AC4TV profile from my KPA. When I try to delete "4W On Fire!" the unit freezes. After pulling the mains and back on everything seems fine but the 4W On Fire is still alive.

  • Unfortunately not. There where two more profiles from rafport.
    "AC4TV" and "4W On Fire!"


    I have deleted the Bogner and the AC4TV profile from my KPA. When I try to delete "4W On Fire!" the unit freezes. After pulling the mains and back on everything seems fine but the 4W On Fire is still alive.

    Do you have Autoload engaged (top right of the screen)? If yes, disable it and you'll be able to cancel it, I just did it

    "Music is enough for a lifetime, but a lifetime is not enough for music" Serghei Rachmaninoff


  • Hi. To be clear (as i really don't want anyone had my problems) i will tell you exactly what i did, what it happen, so maybe this can be of help for all of you:


    1) the only edited tone from me is the Vox one. I did because the profiling compilation is not so clear and you can't go back. Now i saw how to do without edit anything. The Bogner one was profiled properly, never edited.


    2) the boxed effect i had on my KPA before the corruption of the firmware it was even in some of your profiles (i use mine mostly, but at the end it was even in the other profile i was testing). For example i eard on the Petrucci Mesa one profiled from the Axe, and in the JCM 800 and Rivera. It seem not to be present in the bundle profiles but i had not enough time to say because all this happens in a pair of day, and seem going worst time to time. (and i'm not a pro player, i had to work on life so time is limited ;) )


    3) the Vox and the Bogner profiles was used by other guitarists that never noticed any strange behavior. Point 2 and 3 seem to demonstrate the box effect was not into profile, but a bug in the firmware. Even other things you read after seem collimate this hypothesis.


    4) my KPA crashed easily if i play with the cabinet setting from the day 1, it did with bundle firmware, it did with the 6900 (my actual firmware). Maybe it is a common bug, but if your KPA won't crash moving values and changing cabinets, mine it did before any profiling or any save of my data. Had problem with cabinets from very first use.


    5) when i did a restore, hoping to solve the boxing bug, i did a restore of a polished Kemper Amp so no profile added from bundle, not mine, not your, so not editing of any kind can cause the block. It was a backup of the brand new KPA. The USB was well formatted, so no corruption in the backup and no error appear during restore (it should do a checksum before start): it end and after reboot KPA can't end the boot. More: to be safest, before the backup i deleted all my profiles, all my cabinets, all my snapshot. I went as prudent as i can be.


    6) error is on the /framework/midi directory, i never connected any midi peripheral to my KPA, it was on my future plan but at the moment was side to my Mac so i really don't need any external pedalboard. So i never changed any setting value into the midi parameters.


    ---


    I received just now a mail from support, i've not a solution but maybe we're going for... i cross my finger. I let you know, i guess anyone will be happy to know a corrupted firmware can be restored (as the code now has various bugs and the KPA is a very complex piece of hardware/software) without shipping.


    Anyway, i don't thing that the edit of the profile to change "Me" in "Rafport" is connected with all the bugs it happens. If a such change can produce all this deadly effect (even after be canceled!) any serious bug is present somewhere. The worst things should happen for a bad profile is to crash when you load it (the right thing is to refuse the profile). All this seem different. Anyway i'm not a technician (to be honest i am but not for the KPA :P ) so i really can't be sure of anything. I want just to play (and profile, i've some other interesting things to profile and share)

  • Unfortunately not. There where two more profiles from rafport.
    "AC4TV" and "4W On Fire!"


    I have deleted the Bogner and the AC4TV profile from my KPA. When I try to delete "4W On Fire!" the unit freezes. After pulling the mains and back on everything seems fine but the 4W On Fire is still alive.


    I'm so sorry about this, i really don't intend damage anyone (i wanted do just the opposite, share some nice tones!). Anyway, just to put more confusion, when i deleted my profiles i have any problem and any crash. Different behavior form KPA to KPA. It seem also that there are some major bugs in the profile loading, and maybe my "bad story" will be useful to a proper check for strings and values before load into memory and generate errors or overflow.


    To be safer anyway i deleted the link for the Vox tone, and i will profile again in future, so if something "deadly" is on it (my nick? ?() no more users will touch it. Newer firmware anyway really need to see those bugs solved.

  • I have deleted the Bogner and the AC4TV profile from my KPA. When I try to delete "4W On Fire!" the unit freezes.


    I have that problem when deleting rigs too sometimes. But the unit is not freezing. It just isn't displaying the "are you sure?" box. If you press Exit or Softbutton2 (it's the Yes) then everything will work again ;)

    MJT Strats / PRS Guitars / Many DIY Guitars -- Kemper Profiler Rack / Kemper Remote / InEar