Communication with profiler blocked

  • Hi


    Just got my Kemper today, got it up an running, installed the latest firmware, installed the latest version of Rig Manager on Mac OS High Sierra. Every time I try to start Rig Manager it gives me the following error....


    "Communication with profiler blocked. You need to enable Rig Manager’s system extension in Security & Privacy System Preferences." ON entering System Preferences, there is nothing relating to Rig Manager.


    Anyone else seen this issue?


    Thanks


    JM

  • I have the same issue that you are referring to and for the life of me I cannot figure it out. Even after spending an hour on the phone with Apple support they went through all my computer settings and were also at a loss. They believed it was something in Rig Manager that might be effecting the ability to communicate with security preferences.

  • HEY!
    I had the same problem, but i fixed it. I'm on OS High Sierra 10.13.2 .


    I Started with updating my profiler via Flash drive, and updated my rig manager to the latest version


    I found the Kemperprofiler.kext file from the content of the program package. (this is the file that you are asked to allow to be moved into system extensions folder)


    Then I moved it to the extension folder inside the library folder of my computers disc. (MAC / library / extensions)


    I restarted Rig manager with my profiler connected, and it worked.


    Hope it works for you guys!

  • I hade the same problem and this worked for me:


    1: Removed Rig manager software


    2: Removed the file KemperProfiler.kext from /Library/Extensions/


    3: Reinstalled the Rig manager


    Now everything seem to work just fine :)

  • Wow Magnus, thanks!! After hours of trying to solve this problem, you gave me the right tip :thumbsup:
    This works for me!!