The Simplest Things!!!!

  • I am TERRIBLY sorry. HOW THE HELL DO I WORK THIS DAM*ED THING? Is a college degree required? I just cut the output of a 600W Profiler AMP off, on purpose. That worked. Ok, now, let's reverse the process. CAN'T GET IT BACK ON! This is INSANE! THE F*NG "OUTPUT" light is ON, just like before, but NO! External speaker is quiet! WHY TF IS THIS NOT INTUITIVE?! Ok, all you "I KNOW THE BIG K INSIDE AND OUT" people, don't fuel my fire. AND, HERE IT IS . . . If I inadvertently turned it off, the light should go out. It did. Great! I pushed several buttons, and . . . lo and behold, it came back on. But guess what, NO OUTPUT! My speakers were thirsting for power where none existed. FACTORY RESET! Seriously? C'MON! Can we all say it together . . . HOW ABOUT ACTUALLY "INTUITIVE???!!!" Rant over. Deep sigh feels good. So, I tried SOOO hard to NOT factory reset. WHY WAS THAT NECESSARY?

  • ????


    I've turned mine on and off many times using the same button ( either in the output or system section, can;t remember), no factory reset..also why did you switch it off, its not necessary ( check the manual)??


    Just check:


    You've not accidentally unplugged the speaker cable - I've done this many times
    You've plugged into the input - I have also plugged into the headphone socket
    Check all the other obvious stuff like volume settings ( as there are some link volumes that can confuse).


    Otherwise you might need to raise a ticket as it maybe faulty