Problem updating Rig Manager - Win 10 Pro

  • Hi All,


    I've been trying to update Rig Manager for awhile and keep on having issues. I'm on a Win 10 Pro version 1703 (Creator's Update) and have Rig Manager v2.1.26.13232 installed. When launch Rig Manager, I get the following screen asking if I want to install the latest update:


    -----------------------


    About Rig Manager 2.1


    Features and changes in this version (2.1.40):
    - Improved driver (macOS and Windows)
    - Fixed: Cabinet editable after copying Direct Amp profiles
    - Fixed: Favorites gone after restoring backup and restarting Rig Manager
    - Fixed: Occasional failure on updating Profiler Software (macOS only)
    - Fixed: Crash when disconnecting Profiler during Software Update
    - Changed: Search text cleared when switching between Rigs and Performances
    Features and changes in this version (2.1.26):
    - Fixed: Installation failed on certain Windows systems
    - Fixed: Wrong order of folders in macOS 10.13
    - Fixed: Occasional crash when restoring backup (Windows only)
    - Added: Instrument type "Acoustic"


    ---------------------


    When I click Install Update, it downloads but when the Windows Installer runs, I get the following window pop up with only an OK button:


    ---------------------


    Windows ® Installer. V 5.0.15063.0
    msiexec /Option <Required Parameter> [Optional Parameter]
    Install Options
    </package | /i> <Product.msi>
    Installs or configures a product
    /a <Product.msi>
    Administrative install - Installs a product on the network
    /j<u|m> <Product.msi> [/t <Transform List>] [/g <Language ID>]
    Advertises a product - m to all users, u to current user
    </uninstall | /x> <Product.msi | ProductCode>
    Uninstalls the product
    Display Options
    /quiet
    Quiet mode, no user interaction
    /passive
    Unattended mode - progress bar only
    /q[n|b|r|f]
    Sets user interface level
    n - No UI
    b - Basic UI
    r - Reduced UI
    f - Full UI (default)
    /help
    Help information
    Restart Options
    /norestart
    Do not restart after the installation is complete
    /promptrestart
    Prompts the user for restart if necessary
    /forcerestart
    Always restart the computer after installation
    Logging Options
    /l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <LogFile>
    i - Status messages
    w - Nonfatal warnings
    e - All error messages
    a - Start up of actions
    r - Action-specific records
    u - User requests
    c - Initial UI parameters
    m - Out-of-memory or fatal exit information
    o - Out-of-disk-space messages
    p - Terminal properties
    v - Verbose output
    x - Extra debugging information
    + - Append to existing log file
    ! - Flush each line to the log
    * - Log all information, except for v and x options
    /log <LogFile>
    Equivalent of /l* <LogFile>
    Update Options
    /update <Update1.msp>[;Update2.msp]
    Applies update(s)
    /uninstall <PatchCodeGuid>[;Update2.msp] /package <Product.msi | ProductCode>
    Remove update(s) for a product
    Repair Options
    /f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>
    Repairs a product
    p - only if file is missing
    o - if file is missing or an older version is installed (default)
    e - if file is missing or an equal or older version is installed
    d - if file is missing or a different version is installed
    c - if file is missing or checksum does not match the calculated value
    a - forces all files to be reinstalled
    u - all required user-specific registry entries (default)
    m - all required computer-specific registry entries (default)
    s - all existing shortcuts (default)
    v - runs from source and recaches local package
    Setting Public Properties
    [PROPERTY=PropertyValue]
    Consult the Windows ® Installer SDK for additional documentation on the
    command line syntax.
    Copyright © Microsoft Corporation. All rights reserved.
    Portions of this software are based in part on the work of the Independent JPEG Group.


    ------------------


    When I click on the OK button, the install just ends. Launching Rig Manager again and I get asked if I want to install the update. I done the uninstall/reinstall and that doesn't seem to work so I'm hoping I can get some help here. Thanks.


    Cheers,


    jayson

  • Had the same problem yesterday. I am on win 7.


    Solution was not to update the beta. I had to uninstall the beta, download the 2.1 from kemper website, install the 64 bit version. Than rm starts the non beta version and says update. After that it works.

  • I'm also on Win7. Is there a uninstaller? Can't find it anywhere. I have the same problem: Went through the complete process and then RM doesn't appear anymore. I have Beta version 2.1.40
    Can I just delete in Control Panel?


    Finally removed RM and went to Kemper's website. Downloaded 2.1.40 for Win7 and installed the latest version, 64 bit. No improvement. RM won't start!
    Anyone?

  • I'm on Win7 x64, I updated from the Beta version through RM, and got an error message on the KPA: An issue related to the internal clock has been detected, contact support.


    I pressed OK, and that was the end of the error. 2.1 is working well for me.

  • If this message has only appeared once, you can ignore it.
    In your case, the message was generated because there was a problem synchronizing the internal clock of the Profiler with the clock on your computer while the Profiler was connected to the computer via USB.

  • I have the same problem, the solution is to download the update from the Kemper website. Installing from the rig manager stoped working like 2 or 3 updates ago.

    If you experience problems like this, especially with a beta version, we always appreciate feedback, e.g. via the "Provide Rig Manager feedback" menu entry. The update problem was easy to fix, but I didn't know about it until V2.1.41. was already released. So you will run into this problem one last time when the next update gets available.

  • Just today I finally have been able to install the latest version of RM: version 2.1.41.13351,right from Kemper's website and from yesterday's date: 2018-05-18, filesize 126.71 MB. The beta version in this case caused for trouble because I couldn't uninstall it and this has taken me a while. I kept on receiving a waiting to uninstall message. This was due to having my profiler turned on, so you have to close your amp for this. After this it works again like a charm. So problem solved. :)
    Next question: should I go for a next beta version or is it better to wait for the final version?

  • I'm having trouble too. I tried to update from inside RM and it kept just quitting near the end. So I downloaded the file from the site, and it's giving me "Installation Ended Prematurely" error message.


    So I uninstalled my old Rig Manager, but that didn't do a thing. Except I can't install the previous version because I get the same message in the older version now. Argh!


    UPDATE: got it working. I had to use regedit to delete anything that said "Kemper Amps" in my Registry file. Then it installed without a hitch.

  • Sorry for not following up my post but I did raise a ticket with Kemper and, after providing some debugging files, they determined that my Windows Login was an issue as it's my first and last name with a space in between. They said it would be fixed in the next update.


    Cheers,


    jayson

  • Here's a screenshot of what happens...


    Windows 10 Pro, administrator account, running profile manager as administrator.


    Considering that the past 2 updates have been addressing Windows installations I think there's still something not quite right.
    Last installation I had to go through a lengthy procedure posted somewhere on this forum.
    Hope this gets fixed soon.

  • Problem and solution had been mentioned earlier in this thread. If you have a space in your Windows user name, then the automatic updater of Rig Manager doesn't work. This is a problem in all Windows versions. The solution is to download the latest version from our website. This version will accept spaces in user names and display future Rig Manager updates correctly.

  • Hi Arne,


    Thanks a lot for clarifying, this hasn't worked in the past but this time it did.


    Maybe could be a sticky on the forum? This could save a lot of users from headaches (like myself :) ).


    Cheers!

  • Problem and solution had been mentioned earlier in this thread. If you have a space in your Windows user name, then the automatic updater of Rig Manager doesn't work. This is a problem in all Windows versions. The solution is to download the latest version from our website. This version will accept spaces in user names and display future Rig Manager updates correctly.

    Hmmm. Not sure if that worked. I think I fixed my original problem by downloading 2.1.26 from the Kemper site and the install worked. But I just tried to install 2.1.41 and got the same error messages again. Downloaded 2.1.41 and the install worked again. If it happens with the next update, I'll contact support.
    Cheers,


    jayson