(SOLVED) 5.7.2 MIDI ISSUES

  • I've updated my Kemper with the new OS update 5.7.2 and the Kemper does not respond to or recognize MIDI commands from my RJM Mastermind PBC anymore. Please advise on how to fix. This used to work in previous operating systems. What changed?

  • First thing to check is if the RJM or KPA have had their midi channel changed. It's in the System menu on the KPA, not familiar with RJM to point you on that piece of gear.


    But start with something very basic like a single PC command to call up a rig, performance or however you were using it before the upgrade.


    I use a liquid foot midi controller and there are some changes on programming especially around the reverb slot, but all the other midi stuff continued to work for me after the update.

  • I have both devices set to Midi channel 4. My personal Kemper was updated to the 5.7.2 and no longer will receive the signal. However, I tried the same thing, same midi channel, on a friend's Kemper containing an older update (don't remember which) and they both work with each other as expected. I tried several different single PC commands and my Kemper will freeze up, then eventually shut down. When Midi cables are removed from the Kemper, it responds accordingly.

  • Do you have any other midi devices plugged in to the Kemper or controller? If you do unplug everything but the Kemper and controller as something could be sending something you do not want? Maybe as omni or crosstalk


    Do you have the Kemper plugged in to a computer via USB ? Try unplugging USB and then try foot controller


    Check that your foot controller is not sending extra messages when you select something as it might be flooding the Kemper with too much midi messages.

  • Hmm.. That might be entirely possible.


    Currently my midi devices and channels are:


    1. Strymon Mobius

    2. Strymon Timeline

    3. Strymon Bigsky

    4. Kemper


    I have all of the devices set to their corresponding channels (1-4) and everything is being controlled by the RJM Mastermind PBC. Currently, all Strymon devices are receiving Midi signal and responding appropriately. The Kemper isn't controlling any Midi devices. Just receving

  • The kpa used to crash with a midi overload (sending too many midi messages in a short space of time) im sure this got addressed quite a while back, even to a point where a warning message pops up (if my memory serves me correctly? Or was that just visual indication of incoming midi?)

    Might be possible some sysex or heavy NRPN data is freaking the kpa out with commands it can not handle?


    Can you monitor your midi data using midiOx or something or maybe see if the problem occurs sending PC messages from a different device?

  • Update: There's a setting within the PBC editor titled "Midi Merge" that I turned off and noticed a drastic improvement with what I was trying to accomplish. I'm not quite there yet but getting closer. When I get home, I'm going to run the PBC directly into the Kemper and see if there is any difference in the response.

  • Update:


    I turned "Midi Merge" off on the PBC and connected the Midi out of the PBC directly to the Midi In of the Kemper and it responded correctly without issue. I just now need to figure out how to maintain this with the Strymon's in the equation.

  • TylerMiller

    Changed the title of the thread from “5.7.2 MIDI ISSUES” to “(SOLVED) 5.7.2 MIDI ISSUES”.