New power head - crashes and remote crashes

  • New user here. I’ve got a week left in my 30 day return period with Sweetwater and I’m considering returning my new power head and remote as I’m concerned about stability when gigging.


    The head interface has been crashing. Sound comes out but the controls are unresponsive and the remote dies.

    I haven’t noticed this while in browse mode, only while creating performances. The computer has been connected. I’ve seen threads that mention that the rig manager is buggy and can cause crashes.


    Also - I’ve had several occasions where the remote dies but the head is still working. I’ve needed to disconnect/reconnect the remote to restart it. I’m using the official cable and not a cheap replacement.


    Is the Kemper defective? Is this something that only happens while connected to a computer? If so, is there a way to avoid the crashes and/or not need to unplug and restart? Can these restarts corrupt the data on the Kemper?

  • I did hear back from support (in my spam folder) and they confirmed that it’s the USB problem with Rig Manager.


    Over the weekend, I was careful to disconnect the USB cable while in Performance mode and didn’t have a single crash. Also, at our 3 hour jam (with no computer) the Kemper performed without a hiccup.


    I’m hoping they fix this Rig Manager bug when they put out the new release (whenever that is)

  • Quote

    I’ve got a week left in my 30 day return period with Sweetwater

    Sweetwater is good about exchanging usually. Call them and exchange it with another before the time expires if it keeps messing up.

    If you use FRFR the benefit of a merged profile is that the cabinet is totally separated in the profile.


    For my edification only... :D Kemper/Helix user

  • I did hear back from support (in my spam folder) and they confirmed that it’s the USB problem with Rig Manager.


    Over the weekend, I was careful to disconnect the USB cable while in Performance mode and didn’t have a single crash. Also, at our 3 hour jam (with no computer) the Kemper performed without a hiccup.


    I’m hoping they fix this Rig Manager bug when they put out the new release (whenever that is)

    So RM has a USB issue? Hummm, I wonder is this is why some of us had issues with the beta install on our Macs then recently?

    If you use FRFR the benefit of a merged profile is that the cabinet is totally separated in the profile.


    For my edification only... :D Kemper/Helix user