Profile sending out a thousand MIDI note off messages and MIDI reset msg on startup - why and can i switch this off ?

  • i have an issue with the Kemper freezing up my audio interface when i switch the Kemper on with MIDI leads connected. I'm working with the manufacturer of the interface to figure out why this freeze occurs and i've checked with a MIDI monitor on another MIDI interface and found out that when the Kemper is switched on it sends out around a thousand MIDI Note Off messages on C02 followed by a MIDI Reset message. After startup it sends out active sensing pulses continously.


    I can work around this by disconnecting the MIDI leads which i only had connected because i was trying out the ToastME software at some point and forgot to disconnect the midi cables afterwards. I'm not going to use the MIDI editor anymore since i'm waiting for the new Kemper editor, so it's no big deal, but i'm still intrigued why the Kemper sends out so many redundant midi messages on startup.




    -------------------------------------------------------

    free you mind and your ass will follow …

  • Yes, something is wrong. KPA sometimes generates completely random MIDI commands during startup. Kemper Support #1 ?

  • Hey Thanks DamianGreda many thanks for checking. What kind of midi monitor app are you using? The output you get is much more detailed than mine. It's weird that on your Kemper it sends out various MIDI messages, on mine it only sends out the same note off one thousand times. I'll have to do more tests to see if the messages change in different conditions.


    For the interface freeze it's no big deal but it took me a couple of weeks to figure out where this was coming from ( icompletely forgot that i still had the MIDI cables plugged in so i first was investigating USB and Ethernet issues). For sure the interface shouldn't lock up when it receives midi messages and i'm working with the interface maker to troubleshoot this since it's still a beta hardware/software at the moment so it would help them if we could figure out a bit more about what and why the Kemper sends out these messages.




    -------------------------------------------------------

    free you mind and your ass will follow …

  • Just wondering if you might have a MIDI loop happening here.

    Does it still freeze if the "IN" cable to the KPA is disconnected, of have you monitored what (if anything) is being sent TO the KPA?


    As far as I know, active sense is automatically on. It can be turned off, but only by very special MIDI commands.