Kemper Stage - Loose knobs, broken stomp switches, browser push knob broken & more. Poor Quality?

  • Anyone else finding issues with their Kemper Stages?


    The type knob and now lately the bass knob both are sooo loose to the point of falling off when the unit is upside down. The headphone output is sending out white noise when the unit iss switched off. And the unit froze when connected to Rig Manager and I had to hold the power button down for 10 seconds or more to hard reset.


    Not sure if I have a bad unit or others have experienced similar?

  • Well in my view, it's disappointing , that a brand new product has issues with its software, when it's only just out of the factory.

    Remember Widnows 98 and Blue Screens of Death along the way?


    It's not a medical device anyway. Recently even Boeing released a "brand new product" with buggy software (unfortunately for people on both 737MAX flights).

  • Obviously a few units have been shipped with some kind of test FW (I'm only speculating) instead of a working OS. These owners can be sorted by support.

    Some owners have reported about their RigManager connection being unstable.

    Other than that, what other problems have been reported?

    The OP's report of loose knobs is the first HW report I've heard of.

    This all is not optimal, but disappointing?


    Finding your post mildly exaggerated LiamUK, but of course you’re entitled to your opinion.

    ;)

  • Well it's not 'my opinion' is it? - it's simply what other people have written on here.... Plus, you ask me, "what issues" then go and list them yourself.. lol ;)

    Your opinion is:


    while I keep seeing issues listed on here, I won't be buying a Stage


    then wait until recent problems get resolved by software update, and you're good to go

  • A friend of mine received one with the "Test Software". He just exchanged it for a new one.


    I thought mine was safe, but yesterday on its first gig the 3rd Stomp Switch Started acting up. I thought it was like a software thing, but it's intermittent on either browser or performance mode. Sometimes when I press hard it works... sometimes works at normal...and sometimes it does nothing at all.


    Already opened up a Support Ticket, but thought I'd post it here for the benefit of everyone!

  • Hardware issues: The knobs being so loose they fall off is dissapointing, I cant seeing this unit surviving the "stage" if it cant survive the house. With your 3rd stomp not working, it could be a faulty stomp switch? Looks like some units just were not checked right.


    Software issues:

    Anyone know how to spot if you have a test software or proper OS? Mine's screen has frozen. Rig manager has frozen and wont close so i have to restart my computer. Hopefully they fix this white noise headphone output issue. All those are software related it seems. Be good to know if these are from test softwares?


    Crazy to ship these units with such obvious flaws, just worried other things may be lurking that arent as easy to spot right away. To be safe I think I will exchange mine before I over run my returns period (if thats a thing)

  • A friend of mine received one with the "Test Software". He just exchanged it for a new one.


    I thought mine was safe, but yesterday on its first gig the 3rd Stomp Switch Started acting up. I thought it was like a software thing, but it's intermittent on either browser or performance mode. Sometimes when I press hard it works... sometimes works at normal...and sometimes it does nothing at all.


    Already opened up a Support Ticket, but thought I'd post it here for the benefit of everyone!

    Hi!

    I have the exact problem with mine. Only that it is the first Stomp Switch in my case. I contacted the support today.


    Gear: Kemper Profiler Stage
    Guitars: .Strandberg* Guitars | Mayones Regius |