FW 7.1.0 Public Beta Feedback Thread

  • OS 7.1.0 public beta now available for all models


    From Burkhard:


    OS 7.1.0 public beta includes the following improvements:


    PROFILER Operating System 7.1.0.15112/15113


    User Interface


    fixed: no audio processing of MIDI control changes #1, 4, 7 received

    fixed: not restoring backups from USB memory drive while USB cable is plugged in and connected to PC/MAC

    changed: responsiveness of knobs when dialing parameter Pitch


    Thank you, team!

  • Monkey_Man

    Changed the title of the thread from “FW OS 7.1.0 Public Beta Feedback Thread” to “FW 7.1.0 Public Beta Feedback Thread”.
  • Lots of trouble here ... I 1st upgraded RM and I lost connectivity to my KPA


    Had to upgrade to 7.0.9 with USB token since no connectivity , install crashed , but after a reboot , it was OK , preset management available ! BUT I lost all of my Rigs on my KPA , expect the one that was loaded before the upgrade ( hopefully my most versatile one ;)


    had to reinstall RM from scratch after a deinstall process , then connectivity was back.


    Installed the 7.1 this morning from RM this time, still not able to ket my KPA backup back from my USB token, with or without USB cable plugged...


    Could not batch upload my personal collection back to my KPA from RM, I had to manually double click on a rig before being able to upload it to my KPA (once at a time , but RM crashed just after sending one rig ...). EDIT : uploading a rig to my KPA does not allow to store it , I still have 0 rigs stored on my KPA... I can only use the KPA with RM for rig selection and browsing ATM.


    BE SURE TO MAKE RM backup and KPA backup before upgrading , hopefully I did all these !!


    Sounds like a nightmare here , but not as I'm not gigging & only recording at home.


    And BTW I really appreciate the new preset management.

  • I'd send the KPA team a backup to they can try and replicate this issue and solve it for you

  • From what I experienced with OS7 versions and from what I read on forum, there was never any 'release' ready version. Release 7 shipped with Stage was problematic, it was really a 'beta' but renamed to 'release' so the Stage could be shipped to customers.


    How is it that there are bugs in new versions not related to any added new functionality? I tried few OS7 for my Head, but there were bugs, so I went back to OS6. Two of bugs I experienced: all snapshots were not showing (after downgrade, they reappeared), gui frozen, waiting indefinitely when I tried to browse effects. Don't tell me to contact support. I am not beta tester and I don't want to become one. I just tried it, it didn't work I don't complain, it was 'beta'.


    But I see, we have 'release' version with bugs such as, not responding to MIDI messages. Do the developers use any automated testing of new OS before they release it to public? I cannot imagine such bugs would come through automated testing.

    Or maybe the sw has gotten to a state in which bugs like to pop out when unrelated functionality is changed?


    Seeing this phenomenon, I didn't even bother to try 'release' version as it seems it's not ready yet.


    In the past, I remember there was such period when we experienced similar problems with many bugs in new versions. Then the sw was rewritten and all went back to normal.


    Hope it will get sorted out soon.

  • I read that they are using a database approach for storing rigs in OS7. Sounds like a lot of issues might come from this.


    Rig Manager opening rigs which are not present, MIDI CCs make the thing crash (pointer exceptions), missing rigs, wrong backups, etc.

  • Still rocking some OS 5 release here while I've been into this never-ending recording project... looking forward to upgrade soon but at the same time, I don't get the obsession to always be on the latest betas. Those earlier releases were rock solid.

  • My upgrade went ok. This does fix the midi volume/wah/pitch issues that I was experiencing.


    Did have to go and reassign about 5 out of 128 rigs for midi PC information, which took just a few mins. Everything else seems to be working so far.


    Thanks Kemper team.

  • So I did the update too. First the thing got stuck at "importing midi tablet" or something, than it got stuck again. Next try worked. But the sounds now clipped my soundcard, every rig was very loud. I did restart the Kemper and now the volume is back to normal. Strange.


    But something still sounded "not so good anymore". Solution? On my device the "pure cabinet" feature was activated again in the output menu!

  • Okay I'm on the KPA Stage, just upgraded to 7.10 and it appears zero problems now. I'm not having the crash when switching between performance profiles quickly. But I've only seen that once since moving to 7.09. Backup and restore function seems to be functioning correctly.