Rig Manager does not connect with Kemper with latest Update

  • Hello everyone,


    I just updated the Kemper Rack Firmware to Release 7.3.1.16224 and the Rig Manager to Version 3.0.117.16214.


    Since I did this, Rig Manager does not connect to the Kemper. It does not show my performances and the Kemper does not show the "performance syncing" dialogue, which it used to show when connected to Rig Manager.


    Is this a known issue? What do I do?


    Greetings, Alex

  • This happened to me yesterday when I set up Kemper on a different laptop last night, long story short, I hadn't updated Windows on this particular laptop for around two months. Updated Windows 10 and it solved the problem.

    I went through the usual fixes beforehand of syncing the name of the Kemper with Rig Manger, uninstalling RM, turning off on a half a dozen times. My problem was solved with the good old update Windows fix.

  • This is an interesting issue, I haven't seen this myself but there are a few users (when you take the amount of users we have into account) who face above after an update.


    In many cases, rebooting Windows and also Rig Manager seems to solve it, sometimes you need to de- and reinstall Rig Manager to make it work. In any case, if you face the issue, please contact support and we'll request a couple of files from you. With a little luck we'll either have a fix or at least some decent info on how to solve this.


    thanks, gs

  • This happens to me after a little bit of time has passed. I would try to change profiles and it would not change on the profiler. I would have to restart Rig Manager and then it works. Windows 10. Latest KAOS and RM...

    we need to be careful to not mix things here.


    if your Rig Manager connects fine and then looses the connection after some time, that has nothing to do with a situation where you can open Rig Manager and it doesn't find your Profiler. Maybe you want to use a different USB port / cable / hub (or better no hub for now) and see if that changes anything.


    If you're one of those how start Rig Manager and Profiler cannot be found, a good staring point is to check if your Profiler shows up in the device manager. the result can be "not at all" / "as an unknown device" / "a device called Profiler". this way you can narrow it down further. Mac users can open the USB tree in System Information and check if the Profiler is visible. If you cannot see it there, look for another cable/port/hub.

  • It has only started to happen since I updated to the most recent version. All other versions worked. I don't use a hub.

    The Rig Manager still shows the effects control window but drops the connection to the profiler. So it's not a case that Rig Manager cannot find it. It already found the profiler but drops it after a period of time.

  • I was having a similar issue, when Rig Manager opened, the KPA and profiles were not being recognized and loaded.


    I unplugged and re-plugged the USB-C into my MacBook a few times, trying to trigger the Mac and Rig Manager to see the KPA. Was not working.


    After several tries, I decided to try the same thing, except leave the USB-C end plugged into the Mac, but unplug the other end of the cord from the KPA, re-plugged the cord into KPA and it loaded the profiles as expected. Never dropped connection on me, as some are describing. Just the initial failure to load and recognize, is all I have experienced.


    Using Mojave 10.14.6 on a Macbook Pro, using a USB to USB-C adapter.

    Hope this helps someone.