Crackles using Kemper Stage SPDIF with Apollo Twin x

  • Hi, I try to record my KPA Stage via SPDIF using an Apollo Twin x interface in Logic Pro x. However despite trying different toslink & coaxial cables, digital converters, synchronizing and trying different sample rates, trying different SPDIF clock settings (master or slave) I always get once in a while every 10 seconds or so annoying crackles. Init globals also did not work. The software is updated. Am I the only one with this problem? Your help is very much appreciated. Thanks!

  • The right setting is to have the Kemper as a slave - otherwise you'll get crackles. Are you confident you have tried this? I have also experienced crackles after a software update even with the correct settings, but those have stopped after a reboot of the Kemper.

    Kemper PowerRack | Rivera 4x12 V30 cab | Yamaha DXR10 pair | UA Apollo Twin Duo | Adam A7X | Cubase DAW
    Fender Telecaster 62 re-issue chambered mahogany | Kramer! (1988 or so...) | Gibson Les Paul R7 | Fender Stratocaster HBS-1 Classic Relic Custom Shop

  • I had the same problems with an Apollo X4. Here's what I did and it seems fine (although I note, you've pretty well got / been there but perhaps start again).


    1. Reboot PC and Kemper.

    2. On output. SPDIF output to Master Stereo (although this won't be the source of your issue).

    3. Page 5 of Output, set clock speed to 44.1k. Check SPDIF out link at the top.

    4. In the UA console click settings, hardware and check that 44.1k is the sample rate and S/PDIF is the clock source.


    Good luck.

  • Thanks for your advice. I took those steps as I had before. Unfortunately without any major change. The crackles occur only once in a while but they are bothering and unacceptable for recording.

  • are you using a Spdif adapter or converter to connect your audio card to the Kemper?

    I use a toslink coaxial converter (I have tried 3 different with a similar result), tried 2 different coaxial and 2 toslink cables (no differences). SPDIF out from the stage goes via coaxial cable in the converter and from there out as toslink in the SPDIF in of the Apollo Twin x interface. Unfortunately my interface has only an SPDIF in but no out.

  • Hmmm. You definately have the digital input on the Apollo under settings - hardware, set to SPDIF?


    Is SR Convert above the S/PDIF faders turned on (should be)?

    Yes! The days before I got more crackles when I switched instead of SPDIF to internal. Yesterday that even didn't make a difference. I also tried in output section page 6 all combinations to mark or unmark SPDIF Out Link and/or Internal without any difference except that unmark Internal leads to auto which my interface doesn't like. It starts to switch then every 20 seconds or so.

    Hmmm. You definately have the digital input on the Apollo under settings - hardware, set to SPDIF?


    Is SR Convert above the S/PDIF faders turned on (should be)?

    The SR Convert was off. However, to switch it on didn't make any difference. What does it mean? In the Console settings Alt Count stands on 0 whatever this means!?

  • I use a toslink coaxial converter (I have tried 3 different with a similar result), tried 2 different coaxial and 2 toslink cables (no differences). SPDIF out from the stage goes via coaxial cable in the converter and from there out as toslink in the SPDIF in of the Apollo Twin x interface. Unfortunately my interface has only an SPDIF in but no out.

    well my advice get an audio card with SPDIF,i have the Focusrite 6i6 and i have zero issues,i read on some forum that toslink coaxial converter have too many issues.

  • well my advice get an audio card with SPDIF,i have the Focusrite 6i6 and i have zero issues,i read on some forum that toslink coaxial converter have too many issues.

    You might be right that the converter construct is the problem. However, if so I hoped that others would have already overcome and found a converter that works!?

  • I'm using this one https://www.amazon.co.uk/times…link-Socket/dp/B01ET10M26 with my Apollo Twin USB MkI (1!) with little issues, but I must say the need to always remember to make the Kemper the master makes me consider going back to analog. More than once I had to scratch a good take because of it.

    Kemper PowerRack | Rivera 4x12 V30 cab | Yamaha DXR10 pair | UA Apollo Twin Duo | Adam A7X | Cubase DAW
    Fender Telecaster 62 re-issue chambered mahogany | Kramer! (1988 or so...) | Gibson Les Paul R7 | Fender Stratocaster HBS-1 Classic Relic Custom Shop

  • I'm using this one https://www.amazon.co.uk/times…link-Socket/dp/B01ET10M26 with my Apollo Twin USB MkI (1!) with little issues, but I must say the need to always remember to make the Kemper the master makes me consider going back to analog. More than once I had to scratch a good take because of it.

    Looks similar to the ones I tried. If it would work out the necessity of having the Kemper as the master wouldn't bother me. But it looks like that I have to record analog anyway.