Can't update KAOS

  • I'm having some weird issues upgrading my Kemper unpowered head to OS 7.4.1

    My Kemper is currently on 7.1.7 public beta OS

    I started by trying to upgrade from RM 3.0.1 - it recognizes the Kemper and I get the pop-up saying it will search for the latest firmware. I waited about 15 minutes or so and never received another pop-up to upgrade the software. Also noticed that there is an exclamation point in a triangle next to My Kemper under Local Library and shows 0 amps installed (which is incorrect)

    Next I tried upgrading over USB - first formatted the USB stick successfully on the Kemper and then connected to my PC and dropped the bin file in OS update folder. Plugged it into the Kemper and no pop-up, nothing came up after waiting for a minute or so. It recognized the USB stick no problem but never received a prompt to update. I moved the kaos bin to the root and same result.

    So I figured maybe I just had a bad download and downloaded the OS upgrade files again and tried the same process and same results no pop-up, nothing.

    Next I tried turning on the Kemper to Tuner with <> pressed down and it immediately showed Error: invalid file

    So next I tried another USB stick and repeated the whole process but was still unsuccessful in all my attempts.

    Just for kicks I put it the bin file in the root and the OS update folder and I got a pop-up this time saying that it couldn't update because there are multiple upgrade files on the USB stick. So it does recognize the bin file in some way and just refuses to prompt me to upgrade (I knew this would fail but I hoped it would tell if it recognized the bin file or not and indeed it does in some way)

    I'm not sure what other options I have at this point, I think I've isolated every part of the process. Maybe the current firmware is somehow corrupted but it operates just fine normally. Still not sure why it's not working properly with RM though.

    Anyone have any other ideas that I could try?

    Thank you!