Whats wrong with RM and Performances?

  • Is RM totally useless with Performances?


    I copied a performances from a Kemper slot into the local library in RM. I edited the performance in the local library and stored it. But when I went back to the Kemper slot, RM had also changed the name and the performance on the Kemper. The performance on the Kemper was "destroyed" and over written by the performance that was updated in the local library.


    This happened twice, and I did not push any wrong button when I saved.


    For me this seems like a total mess?


    Is this by design or is the code in RM really really buggy?

  • Short answer is yes. I'm afraid at this point performance handling and RM could use a complete rewrite. Something must be fundamentally wrong with the approach in the implementation. It can't be that hard :)

    Kemper PowerRack | Rivera 4x12 V30 cab | Yamaha DXR10 pair | UA Apollo Twin Duo | Adam A7X | Cubase DAW
    Fender Telecaster 62 re-issue chambered mahogany | Kramer! (1988 or so...) | Gibson Les Paul R7 | Fender Stratocaster HBS-1 Classic Relic Custom Shop | LTD EC-1000 Evertune

  • My tactic is to never use RM when profiler is in performance mode. I create rigs in RM but I manage performances on device itsef. Sucks a bit but works reliably. I lost a lot of time trying to find a viable solution, all in vain. Filed tickets to support about this RM issue months ago - no solution in sight.

  • I too have found managing performances with RM frustrating. Updating and saving on RM sometimes saves to the KPA.....sometimes it doesn't. Sometimes I'll rename a slot and it reflects on the KPA....sometimes it doesn't.

    Very frustrating.

    “Without music, life would be a mistake.” - Friedrich Nietzsche

  • I too have many issues using RM on my Mac. For example, move a rig from, say, slot 8 to slot 3, I'll end up with two slot 3's in RM and can't use the Remote to switch between slots. Other times I'll create a new performance, save it, then it disappears. The biggest issue is trying to edit performances. Saving it in both my Profiler and my local library, do some edits in the local library, the edits carry over to my Profiler, NOT what I wanted (I wanted to try some different things with a performance, but didn't want the edits to change the original saved in the Profiler). In general, editing a performance is somewhat hit or miss as to whether the edits stick.


    Now I use RM to create a new performance, but am VERY careful not to mess with it once created. It's workable, but not real great. I'd love a new, updated RM that actually works for performances!

  • A workaround could be to first create and edit a performance in the local library. when you're done, place it on the profiler. i believe i have less issues when i work like that.

    Thanks! But I actually tried that. I copied the performance into the local library and edited it there. But when I got back to the Kemper the performance was also changed there. It's really really strange.

  • I am also using a mac to try and edit a performance together in rig manager. I have the performance named and all the slots filled but I can't figure out how to get it into my kemper stage. Seems like I should just be able to drag and drop it into the profiler which is connected via usb.

  • I too have found managing performances with RM frustrating. Updating and saving on RM sometimes saves to the KPA.....sometimes it doesn't. Sometimes I'll rename a slot and it reflects on the KPA....sometimes it doesn't.

    Very frustrating.

    Couldn’t have described my afternoon better.

  • Same for me. Being in the profiler performance mode, sometimes I switch to Rigs in RM and if I select a rig, it is stored in the profiler active slot. No undo and no store button to validate, or any popup saying "are you sure". Don't understand why this was never changed.

  • Same here. Really really buggy. Sometimes copying a rig from browser into performance slot wirks, sometimes only the name in the slot is updated but the sound not. Sometimes the name of the slot gets the name of the rig, sometimes not.


    Sometimes clicking on slot selects another performance.


    As of now quite useless.


    Newest Rig Manager on Windows 10 64bit.

  • I have spent hours today being frustrated by RM and Performances, so I thought I'd post on the Forum and see if anyone could help. And what's the first thing I see? A long thread about how cr*p RM is for Performances. I echo all the above. It sucks. Unusable.


    The signal chain pane at the bottom of RM is fantastic - I can see that a *lot* of development effort went into that. It's elegant, intuitive, closely linked to the Profiler when previewing. Really lovely. Tip of the hat.


    However, everything else about RM feels just ill conceived and poorly designed/implemented. I speak from 30 years of writing software for a living. It needs reimagining, not polishing.


    Please, Kemper, take a step back and do it right!

  • I have been using Kemper Stage and Rig Manager for more than two weeks now. I have lost several times the edits that I did on RM and firstly I thought that I did something wrong. Then I have realized that the mistakes are occurring randomly under the same conditions. It seems like the Rig Manager is disconnecting from time to time. In general, no matter how many times I am pressing to "Store the preset" button the changes do not reflect in the profiler. Sometimes (because I do not see the preset on the device) I am also pressing the soft "store" button and bum the preset in the RM is gone. Several times my "stored" rigs were overwritten mysteriously with the last preset that I just had a look at. I have faced too many errors of different types so I am pretty sure that this case is well known by the Kemper Team. Hope that we will receive a solid solution with more reliable software...

  • I have to join in with the Chorus since there seems to be obvious issues with the current version of Rig Manager and (I hope) they are aware of this.

    I have owned a Kemper for 6 years now and this is the worst shape Rig Manager has ever been in!

    Please fix it fast! I can't rename Rigs amongst other problems.

    Is there anyway to go to a previous version?

    You know I'm born to lose, and gambling's for fools
    But that's the way I like it baby
    I don't wanna live forever