Kemper amp died, potentially killed speakers, laptop and finally itself.

  • Ok, today has now escalated into officially one of those days.


    Updated to the newest firmware the other day. Today I went to plug the main left into my maudio sound card and as loud pop happened.


    Long story short. Goodbye krk rokits... Goodbye msi titan gt63 laptop.


    Couldn't figure out what it was, thought I'd try plugging the main out into another guitar amp. Another huge pop and now the kemper is dead too.


    Support has been contacted, unit is 2 or 3 years old. Laptop is 4 months out of warranty.


    Be careful what you plug into.

  • So that's it, this amp took out (including its own value) $5,000 of equipment and the final verdict is that I'm gonna have to pay for the parts for repair as 'this type of damage is not covered under warranty.'

    Most dissatisfied. I don't really know how to move forward with this as even if I do have it repaired, what guarantee do I have that it doesn't fry the next thing that I plug it into? What if I'm at a show and it kills a mixing desk or entire PA system?

  • How would the XLR output section of the KPA, which has no real voltage, possibly overload, let alone damage your equipment? We're missing some details to this story.


    Do you have a digital multi-meter to test the XLR output voltage with?

    Kemper Powerhead w/remote & Kabinet
    Focusrite 18i8 (2nd Gen) - Windows 10 - Ableton Live - Yamaha HS-8's - DT770 80 ohms

  • How would the XLR output section of the KPA, which has no real voltage, possibly overload, let alone damage your equipment? We're missing some details to this story.


    Do you have a digital multi-meter to test the XLR output voltage with?

    I have no idea how this could happen.

    My speakers and laptop went at about 11:30 am. I plugged the unpowered out into a guitar amp at about 3 to check to see what happened (at that point, the only piece of gear that was working was the profiler). Sure enough, that made a huge popping sound and now the profiler is still stuck in a boot loop.

    I could turn it back on and see if there's any voltage coming through the xlr output on the back but it's still in the boot loop.

  • A safety warning :


    Just make sure that there´s no malfunctioning electric cables or outlets

    that have made the KPA housing electric instead of grounded, and

    thereby even made the XLR ´s ground / shield electric .... Hense the

    big pop when connecting to other gear ...... =O

  • sorry but i don't think that this is a kemper fault, you say there is high voltage at the xls ,but thats nearly impossible

    maybe check your power outlets in your place

    maybe somethings wrong there

    I have no idea how it's possible. If you asked me before Saturday, would I have any hesitation plugging the main output XLR into something, I would've said there's NO CHANCE it could go wrong. We just moved into the house and have had a certified inspection carried out on everything including of course the electrics.

    I just know I plugged in the XLR to the soundcard and POP. Then hours later, I plugged it into a sacrificial guitar amp (I of course had to use XLR to 1/4" converter to do that) and another POP. That time the profiler died.


    Of course it is possible some strange and unknown power surge happened twice, once to kill the laptop and speakers and another to kill the profiler but realistically, I think the thing that the events had in common was that they both used the kemper's main out.

  • Yes sir, I am plugged into a Furman surge protecting power strip before the wall outlet. We've had electricians in the house before we moved in to inspect and certify their inspection. House is not something I am worried about.

  • Something fishy with that Furman ? :/

    Could be. It is quite new. Here's the strange thing too though. My kabinet was plugged in the monitor out of the profiler the entire time and was working throughout!

    If the power was the problem, I figured the profiler itself wouldn't have functioned. It only malfunctioned when something was plugged into it.

    Nothing else was plugged into the Furman.

  • Strange indeed ......


    BTW, how does your kabinet make sound when connected to the monitor out ?

    There must be some power amp to , right ?

    Or do you have a powered KPA ?


    Not that it matters now when it is "toasted", just wondering .........

  • Jamesc


    I can only advise to get somebody to check the electrical situation.


    There is absolutely no way you can can damage a laptop and active speakers with a Profiler unless you either do something fundamentally wrong, the unit is damaged in a way we never have seen before. Maybe there is an outside factor such as the cabling of your house etc. I understand that this must be totally frustrating, possibly an issue you can forward to your insurance though.


    For the safety of the people living at this place, you should find the reason behind all this.

  • I actually think it's sounded strange for a while. I opened a previous support ticket and set recordings. Support staff said they thought it sounded ok.