Broken middle/treble poti

  • Hi,


    i got a used PowerRack from a store today. After updating the firmware i started checking everything (can't tell if the error occured before the firmware update). The middle and treble poti seem to be broken. Is there a software solution or should i return the kemper?

    I uploaded a video to demonstrate the error:


    Best regards

  • A broken pot is far from the end of the world, I have repaired broken plastic pots too many times. I use plastic welding solution or epoxy resin, done well it will be like nothing ever happened. BUT I would not do it if you have no experience doing any of this, as the worst might hapen and a drop of resin/solution can go into your pot cavity, rendering it useless forever. So I suggest you ask support too, so they can help you in the best way possible. Changing the pot needs some soldering, so again, most likely you need to send it to support.


    As a last note, broken pots is not the end of the world, especially now we have the editor, you can always use that to get your tone and then save it.

  • @Alfahdj i got the product from a shop with a pretty good reputation as "second choice". Its not a kemper which is 10 years in use. It was sold with the note that is has some little scratches underneath.


    Going to contact the dealer, reset didnt help. Thank you all!

  • You need to spray some contact cleaner on the pots inside, and spray "liberally" ( a lot) to flush out the dirt. Let it sit for a couple of hours then play.


    In the meantime, use Rig Manager.

    If it is a new KPA i strongly advidse against it. Contact cleaner can easly get between the display and display led backlight foil . It will create darker area becaouse the fluid it will have nowhere to evaporate.

    I used this method with my KPA but only with 2-3 sprays on the encoder.

    But my KPA is no longer under warranty.

  • If it is a new KPA i strongly advidse against it. Contact cleaner can easly get between the display and display led backlight foil . It will create darker area becaouse the fluid it will have nowhere to evaporate.

    I used this method with my KPA but only with 2-3 sprays on the encoder.

    But my KPA is no longer under warranty.

    He said he bought "used".