KPA owners using SPDIF - check this setting to avoid heartache!

  • Hey all,


    I use SPDIF all the time for tracking and reamping. It's part of my workflow, especially when I record pedal steel - I have templates set up in Pro Tools to record the steel via DI (SPDIF), Stack (SPDIF), and time based effects (DLY/REV Wet via main XLR outs). I also reamp via SPDIF if I do any editing on the DI track.


    I recently upgraded to the latest Kemper OS, and I started having a weird issue. I always set the KPA as my SPDIF master clock source - since it was made before 2018, it can't function as a SPDIF clock slave. ***EDIT-This turned out to be an incorrect assumption - see below - my KPA was made in 2018***

    No problem, I'm already accustomed to changing the clock source on my interface (Apollo 8 ) whenever I use the Kemper. But, after the OS update, the Apollo would lose clock sync randomly. The clock source would flash red on the Console app, and the audio would mute as it searched for the clock. After the audio came back, suddenly my session was playing back at the wrong pitch, about a quarter tone sharp! Being that I play an instrument without frets, I immediately thought it was my fault and tried to correct - but I'm like, wait. Something's up.


    After spending about 2 hours troubleshooting, using contact cleaner on my SPDIF cables, ordering new SPDIF cables (I didn't cancel the order, always good to have spares), I figured out what happened. In the Output menu on page 6/8, there's a checkbox where you can select Auto or Internal for the sample rate. Auto makes sense if you have a post-2018 Kemper that can slave to an external clock source - it just does it for you, no effort required. But if your Kemper is older, definitely switch that back to Internal, and continue setting the Kemper as your master clock source! I guess the new OS had Auto selected by default.


    Update: see below - if the Auto option appears, the KPA can function as clock master OR slave. 8|:):!:

  • The Auto/Internal option only shows up on Profilers that were made after a certain date. Yours was build in summer of 2018 which explains why the option showed up when you updated the OS. You can use your unit as a SPDIF slave or master. Owners of Profilers build before 2018 will not see that option.

  • Lucky bastard :)

    Kemper PowerRack | Rivera 4x12 V30 cab | Yamaha DXR10 pair | UA Apollo Twin Duo | Adam A7X | Cubase DAW
    Fender Telecaster 62 re-issue chambered mahogany | Kramer! (1988 or so...) | Gibson Les Paul R7 | Fender Stratocaster HBS-1 Classic Relic Custom Shop | LTD EC-1000 Evertune

  • Interesting! So it will work either way. That's very cool to know. I guess by having Auto turned on and setting the Kemper as clock master, I created a "who's on first" situation where the Apollo and Kemper kept trying to reference each other, and things got screwy.


    Thanks!

  • Bryan Daste

    Changed the title of the thread from “Pre-2018 KPA owners using SPDIF - check this setting to avoid heartache!” to “KPA owners using SPDIF - check this setting to avoid heartache!”.
  • If you choose "Auto" the Profiler will be the slave as soon as it detects a SPDIF clock at its input. Setting it to Internal makes the Profiler the clock master. If the Profiler is set to Auto and the interface is set to be the slave no sync is possible because both units are waiting for the incoming clock.

  • Totally - I get it now! The good news for me is that I can just set it to Auto and never have to touch it again. Gone are the days of switching my clock source every time I use the Kemper (and manually choosing a sample rate on the KPA). Life is good :-)