S/PDIF output - no signal

  • Heyho folks,


    I want to use spdif for recording/reamping. As an Interface Iam using a Behringer UMC 1820.

    For the connection between the two devices iam using a cheap but working cable (see attachement).


    Kemper settings are set up like in the other attached pictures. I also tried different SPDIF output possibilites. But that is obviously not the case.

    Kemper is master, everything set up to 44.1kHz

    I can't get an Signal from Kemper to the Interface/Computer. Windows audio device manager does display no signal.

    But I can send the test tone to the kemper via spdif and e voila: it does work. I get an overdriven sound (similar to the loaded preset) which I checked thru the main output of the kemper. I also swapped the 2 phases of the cable to check if there is any issue with the kemper out phase.


    I have no idea why it does not want to do what I want.


    What does "SPDIF Out Link" stand for?


    Thank you for your help.


  • Hi Mabo1988 ,


    I'm afraid that you have mistaken the SPDIF connection for an RCA audio connection. SPDIF is a digital connection and what you have there is not a digital (coaxial) cable but an audio cable with RCA connectors. RCA connectors are physically the same as what you need for the SPDIF cable, but the cable itself is not the same. On a sense it's like if you where trying to connect your computer to a router with a power electrical cable instead of the ethernet cable and then wonder why you don't get internet in your PC.



    Once you have a coaxial audio SPDIF cable, then you have to turn up SPDIF volume. In your picture you have it at 0.



    SPDIF Out Link means that you can link that output (you have this option for all outputs of the Kemper) to the physical pot called Master Volume. Any output that is linked (you can link as many as you want) will change it's volume turning that knob. The outputs that aren't linked will remain unchanged when you turn it.



    Let me give you an advice, because you are asking very basic questions about the Kemper. Do yourself a favor and read the manual. It is very well written and the amount of things the Kemper can do you will not be able to learn them "just by using it and trial error". It will take some time but it is completely worth it.

  • first of all thank you for your answer.


    1. the cable what Iam using is an coaxial cable which should work for a test. The surge impedance isn't optimal (I think this is around 50ohm and the optimum is around 75ohm?!) but it should work for a test. my proof: The signalflow from the interface to the kemper is working. Please keep in mind this is my first contact with spdif, so I have no experience with this standard and didn't knew about the so specific "SPDIF cable".


    2. I don't have to increase the SPDIF volume because 0.0dB is the maximum. There is just the possiblity to damb it.


    3. I have read the manual about my issue und could not find the solution. I also could not find the "SPDIF out link" feature.

    Also have read a lot of threads, seen clips but no advice about a specific cable.

  • I believe you are correct on all three points.


    I am not familiar with your particular interface.


    Which DAW are you using? I am only really familiar with the detail of Logic but the concepts are the same for them all.


    As you are able to get sound from the computer to the KPA over SPDIF everything seems to be working. This means the issue is almost certainly a setting somewhere. The KPA is unlikely to be the cause which leaves the interface and DAW.


    Have you checked that the interface inputs are correctly configured to receive the SPDIF signal and send it on to your DAW? Assuming this is set up correctly, the most likely issue is routing within the DAW. Is you DAW channel set to receive the correct interface input for SPDIF. On my Focusrite I have inputs 5 and 6 set for SPDIF. Unless the channel input is set to one or both (stereo) of these inputs and the channel has input monitoring enabled I get no sound.


    For the purposes of testing I would probably use a full signal like Master Mono or Master Stereo rather than Git/Studio as it will be easier to hear but that isn’t a big deal either way.

  • All I can say is that that was not my best post on this forum. Will not delete it but probably I should. Too many mistakes and misunderstood bits.


    In my defense it was late and I probably wasn't in the best mood. Should have gone to sleep and try to help you in the morning.

  • ui, quick and helpfull answers. thanks again.


    at the pictures of the physical connection display you can see which channels the Interface is using for SPDIF (IN: 9-10 ; OUT: 11-12)




    Iam using Ableton 10 but to let the possibility of an issue in a DAW behind me I'm directly looking into the general windows device settings so see is there is any signal:


    For your interestest here the view in Ableton:



    03.jpg


    and here is the Behringer sound setup:


    stabil = stable

    nicht verfügbar = not available




    I have changed the settings of the SPDIF Output to Master Stereo but no signal.

    Is there any else optional possibility in the main output settings of the KPA to "suppress" the SPDIF output signal?

  • FWIMBW RCA cables should be fine for lengths under 1m.


    As distances increase beyond this point you'll start to hear clicks and pops creeping into the audio stream. You may even get up to 2m before noticing anything weird going on, but in my experience 1m or less has been super-reliable.

  • I noticed that the picture of the UMC Control Panel shows Optical SPDIF. However, you are not using an optical connection for your SPDIF. I only use my RCA connector cables so don’t have any experience with optical but I know some devices require a converter to use optical SPDIF with the Kemper. Not sure if that is your issue or not but certainly worth investigating further.


    Also, internal clock is unticked. Presumably you are using the KPA as the Master? Again, I’m not familiar with your particular interface but I suspect the problem lies with one of these two settings. I will never forget the frustration trying to find out why my entire system had no sound (DAW, iTunes, Spotify,Youtube all dead). I finally turned my Kemper on and everything worked perfectly. I forgot I had Kemper set as master so my interface was waiting for the Kemper to let it work 🤦‍♂️

  • yes, this is a discussable topic. I can just set a hook at "internal Clock" OR "optical in SPDIF" - the KPA has to be the master, so - in my logic - i have to remove the hook from Internal clock and set it at Optical in SPDIF (and this doesn't matter for me). Is my logic correct? :)

  • I found it!!! the Interface has to be set to ADAT otherwise it will just receive and send data from the optical SPDIF and not from the coaxial cable.


    Kind of dumb from me - yes, but also kind of dumb from the device.


    Now I will buy a better cable :)


    Thank you for your help!!!!!!!!!!!!!!!!!!!


    PS: still confused why i could send a signal with "the wrong" setting... we will never know.


  • You cannot use RCA cables for S/PDIF connections. While they look similar because of the RCA connector (Phono Plug),it is not the same. SPDIF cables have a stereo digital connection, whereas RCA cables have a mono analog connection. There are no SPDIF to RCA cables, so you would need an RCA to S/PDIF converter to achieve that.


    S/PDIF has 3 conductors like a TRS cable (line left, line right, and ground). RCA has only 2 conductors like a TS cable (line and ground). A TRS cable can work for a TS connection but not the other way around.

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

    Edited 2 times, last by BayouTexan ().

  • You cannot use RCA cables for S/PDIF connections.

    Sorry mate, but this is plain-wrong.


    As I suggested, I used RCA for years. Short runs are fine; it's only when they get longer that the lack of shielding and impedance difference begins to cause signal degradation.

  • That's not correct Tex. Standard RCA will work but only over very short lengths. The difference is really just impedance matching. SPDIF should be 75ohm. You need a convertor for CoAx (RCA) SPDIF to Optical SPDIF but that is a different issue. A digital CoAxial cable still only has the same two conductors as an audio coaxial cable not 3 like a balanced cable.

  • Sorry mate, but this is plain-wrong.


    As I suggested, I used RCA for years. Short runs are fine; it's only when they get longer that the lack of shielding and impedance difference begins to cause signal degradation.

    Maybe because the Kemper only sends a mono signal through a single SPDIF but the ones I've used for other equipment send stereo signals??

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

    Edited once, last by BayouTexan ().

  • Wrong again, brother.


    1) I've never used S/PDIF on Kemper so my conclusion wasn't made based on that.


    2) IIRC the Kemper's S/PDIF I/O is STEREO.


    3) I had my O2R desk hooked up to a MOTU 2408 interface for years with ADAT optical (via expansion cards for the desk) and 2 RCA leads for the 2-bus I/O - 1 for STEREO in, the other for STEREO out.


    There's a lot of misinformation on the 'net about this (surprise, surprise). A quick DuckDuckGo search yielded definitive quotes saying that RCA cables cannot be used / will not work for S/PDIF. They're not-ideal for the purpose but they do work. All these peeps are wrong. I'd even argue that for distances of under a metre, provided no clicks or pops appear, they are ideal if you already have legacy leads lying around and don't want to have to purchase new S/PDIF-purposed ones.