PowerKabinet Problem

  • just received a PowerKabinet. Tried it at band rehearsal sounds great, better than the atomic clr and orange pedal baby with Celestion fx12-200 I have used before. BUT to get enough volume I had to turn the monitor output on full and the Power Kabinet volume on full. Only just right volume to hear over fairly quiet drummer. Doesn't seem anywhere near the claimed 200 watts compared to pedal baby 100 watts. With the pedal baby I had monitor output on -16db and pedal baby volume on 5 at most. Anyone else had similar experience? Please no advice to check global settings or whatever unless you actually have a powerkabinet and know exactly what to do.

  • Hello,

    Same experience from me, I have just received a Power Kabinet, and i tested it at home. I am also surprised by the low volume, even with Monitor output at max. At first I thought that the instrument cable was faulty, but it was not the case. My Deluxe Reverb blows it away in terms of volume.

    So it is OK for home use, but I don't think it would be enough for gigging.

  • I wondered same. And tried even asking if it could be to some conservative input gain/threshold setting.


    Noticed CK mentioning they are intruducing the output boost for powered cab as well in some future OS.

  • Definitely sounds like you have the monitor output control linked to another, higher output. Once the higher output hits max, the monitor output will stay wherever it is, even if that is on “one”.

  • Hi again,

    I contacted yesterday the Kemper support and after checking again the settings, this was their answer:

    "your settings seem fine.
    Have you tried to connect the Powered Kabinet to one of the other outputs (Direct out, Main Outputs) to see if it makes a difference?
    Make sure to select Master Mono as the output source for these outputs in the output menu.
    I cannot compare the Power Kabinet to your other amp but I can tell you that it is very loud under normal circumstances and capable of being used with a rock drummer in the same room.
    You could try to use the init globals function on page one of the System menu to rule out the odd software glitch."


    Output source was alreday on Master Mono, so I launched the Init Globals function. Now, the volume is definitively higher. So I assume there was something wrong with the settings but I don't know where.

  • Guys, you are right.

    This was an oversight of mine!


    The Power Kabinet deserves the same „Power Amp Boost“ Parameter that we have already for the internal Power Amp, allowing a boost of up to 12 dB.

    It has been implemented into the code last week and we will have a new beta software this week.


    Sorry for that!


    As a workaround for today, boost your rigs with the Rig Volume parameter, which has the very same result.

  • OS 8.1.2 is now avaiable as a public beta and addresses this point.


    Power Amp Boost and Wattage Meter - already known from powered PROFILER models PowerHead and PowerRack - are now also available on page Kemper Kone of all PROFILER models to the benefit of KEMPER Power Kabinet users!

  • So what could that "Init Global Setting" thing be. :/ Could e.g. Burkhard comment that can there overall be some setting that is not visible for the user at all or is it always just matter locating the non-optimal parameter behind some menu view (input, output, system, noise gate...)?

  • Init Globals in System Settings resets all global settings to their defaults, which are basically the settings in System Settings and the Output Section.

    While the defaults are usually a good starting point for mainstream applications, the optimum settings depend on what you intend to do.