Chorus effect randomly appearing on performance mode stomp slot

  • TL;DR explanation. Chorus is magically replacing stomp slots, even though the stomp slots still say compressor or delay.


    I am running OS Version Release 8.0.6.24597 in performance mode. I have been running this version since February 2021. Performance 3 slot 1 is MBritt 65 Voice ACE30 N 3, which is a clean AC30.


    In the Stomps section, slot 1 is off, slot 2 is a compressor, slot 3 is off, and slot 4 is a slapback delay.


    In the Effect section, slot 1 is graphic eq. Slot 2 and 3 are off. Slot 4 is reverb.


    The only locked setting is effects slot 1, which is the graphic eq.


    Last weekend, at a gig, I switched to this performance, and suddenly there was chorus on it. It went from being my country/rock edge of breakup clean to sounding like what I'd use for 80s rock clean. I was certain our singer messed with something on the board, so I checked it out and it was fine.


    Yesterday, at practice, the same thing happened. Chorus magically appeared on the same setting. Having more time to troubleshoot, I started disabling effects. When I disabled the compressor, the chorus sound went away. If I re-enabled it, the chorus came back. I held the button for slot 2, and verified it still said Compressor. I copied the compressor effect from a different performance, overwrote the broken compressor in performance 3, and saved the profile. Everything was fine.


    About an hour later, I noticed the chorus was back. I disabled the compressor stomp and the chorus was still there. I disabled the delay stomp, and the chorus was gone. I held the button for stomp 4 and verified that delay was still there.


    I just booted up the amp and took a backup, so I could reproduce the issue and create a support ticket, but so far I haven't been able to recreate it, yet, today. Anyone seen strange behavior like this before?

  • Very strange, I never heard of this myself.

    Be sure to open a support ticket, please. ;)

    I just opened a ticket. I've been trying to reproduce it, today, with no luck. The only difference is, I don't have a MIDI pedal hooked up, right now, but I was trying to use the computer to switch performances using MIDI. I think that would replicate that behavior well enough.

  • Plugged the pedal in and tested going through the various performances I use, switching to tuner mode, and back to performance mode. I couldn't recreate the issue. Only other differences are what I am outputting into, which should not play any part in this. The only other odd thing I noticed was that, after being gone for a while, the issue where the Kemper was skipping performances moving up and down is back. Performance 1 and 2 have chorus in slot 1. Maybe the amp is changing, and the stomps say they are changing, but really aren't. Only problem with that theory is that it appeared in stomp 2 once and stop 4 once. If I can get it to happen again, I'm going to try to unplug then pedal and go up and down with the buttons, to see if the chorus still gets stuck.



    The pedal is a simple 5 button Tech 21 Midi Mongoose, that had been working fine for two years. Odd that the issue started out of nowhere, but I can't reproduce it at home.

  • Have you checked the MIDI cable? :/

    Had a mind boggling issue with some midi gear ( not Kemper ) a few

    years ago and when I was on the verge to throw them out the window

    I changed the MIDI cable and it all worked perfectly again 8o


    Cheers !

  • I had not, but it's certainly worth a try. Thanks for the suggestion.

  • I was able to create the diagnostic file after the issue occurred. The details are below:


    I hooked up the Kemper to the PA system, including hooking up the Tech 21 Midi Mongoose to the MIDI In and a Moog EP-3 Expression Pedal to Switch Pedal 1.


    I verified that Performance 3 slot 1 sounded correct.


    After playing a few songs, which included all slots of Performance 1 and Performance 2, I switched back to Performance 3, slot 1, the issue occurred at 5:14 pm EDT. There was now a chorus effect on this performance.


    I turned off the Compressor on Stomps slot B. The chorus was still there.


    I turned off the Delay in Stomps slot D, and the chorus was gone. I turned it back on, and the chorus was back.


    At that point, I shut the Kemper down and created the diagnostic file.


    When I booted the Kemper back up, the chorus on Performance 3 slot 1 was gone.


    I did notice that there were multiple times when I hit the button to go up a performance that it skipped from performance 1 to performance 3. I thought that problem had been fixed in the last official firmware release. I'm wondering if these two problems may be related, since Performance 1 and Performance 2 both have chorus on.


    I have a gig this Friday, and will be testing a different MIDI cable at it. The other thing I want to test it, after the problem occurs, moving performances up and down with the keys on the face of the Kemper, rather than the footswitch, to see if that causes the problem to go away.

  • The Kemper folks weren't able to reproduce it, but they weren't using a MIDI pedal.


    This is what the MIDI commands look like:




    1 - Performance 2 Slot 1 - PC: Electric Piano


    2 - Go up 5 slots, which puts you at Performance 3 slot 1. This is Generating the PC: Clavinet AND the PC: Music Box commands


    3 - Selected Performance 3 slot 1 again - PC: Music Box


    4 - Got down 5 slots, which puts you back at Performance 2 Slot 1. This is generating the PC: Vibraphone and PC: Electric Piano 2


    5 - Go up 5 slots, which puts you at Performance 3 slot 1. This is Generating the PC: Clavinet AND the PC: Music Box commands



    I repeated the process a few times and it seems to be generating consistent commands. Now, I'm going to have to get the MIDI device hooked up to my laptop and the Kemper at the same time and try to reproduce the issue. The last gig I had, I was trying to move the performances up and down with the buttons on the front of the Kemper, in between songs, to try to alleviate the issue. I don't recall it happening, but it was kind of a crazy night, so I may have missed it. Much easier to troubleshoot when not at a gig.

  • Tried a new MIDI cable for about an hour and a half, yesterday, and couldn't reproduce it. The only difference was I was going into my monitor, instead of the PA (it's at the singer's house). I don't think that should make a difference though. Will test it again at our next practice. Hopefully the cable was the issue. Knock on wood.

  • Had practice yesterday with the new MIDI cable. Had the same issue. After switching performances a few times there was chorus on performance 3 slot 1. This time it appeared on the compressor in stomp 2 again instead of the slapback delay in stomp 4. The only difference between when I tested it at my house is that I was going into the PA system, rather than into my powered cab.


    Once the problem occurs, if I move to Performance 3 slot 1 on the face of the Kemper with the footswitch and then move performances up and then down, the problem goes away. I really have no idea when this started, since we didn't play or practice for about nine months due to the lockdowns. I'm not sure how many profiler OS updates I did since then.


    I have a hard time believing it is coming from the MIDI pedal, because of how simple it is. You cannot change what the buttons do. They are fixed. You cannot reassign anything. There is no way to activate or deactivate stomps using the pedal, and even if it could deactivate the stomps, I do not have chorus in the Performance 3 at all. I also don't understand why the chorus is getting mapped into a stomp that says compressor or delay.


    The manual for the pedal is at https://www.tech21nyc.com/t21manuals/MMG1_OM.pdf if you want to see how simple it is.


    I have gigs Friday and Saturday, so I can't really mess with the Kemper this week. Maybe I'll try to install the new OS after that since I have a two week break after that. Other than that, I'm about out of ideas. I'm not sure I want to spend $150 on another MIDI Mongoose if this is still going to happen. I'm not sure I want to spend $500 on a Kemper remote, and have to worry about drunks at bars around it.

  • Had a gig last night. I used the following workaround, when I wanted to use Performance 3 slot 1.


    1) Go to the correct performance number of the footswitch.

    2) Move up one performance on the front of the Kemper.

    3) Move back down to performance 3 slot 1.


    I did not notice the chorus effect, but I did notice the issue of moving up or down performances is skipping performances (e.g. sometimes going from 3 to 4 actual jumps from 3 to 5. This is using the buttons on the front of the Kemper.

  • Did the same thing, at a gig last night, as the previous night. The issue only occurs when changing performances with the MIDI pedal, but the MIDI pedal is so simple I don't believe it is the culprit. Also, had the performance jump from 3 to 5 multiple times using the buttons on the Kemper. I can't help to think the issues are somehow related.

  • The profiler was definitely involved. When I created those screenshots, I had the the following configuration:


    Tech 21 MIDI Mongoose ( https://www.tech21nyc.com/products/effects/midi-mongoose/ ) into the MIDI input of M-Audio Midisport Uno ( https://m-audio.com/products/view/uno )


    MIDI output of M-Audio Midisport Uno into Kemper Profiler MIDI input


    USB output of the M-Audio Midispot Uno into my desktop PC, to monitor the signals.


    I tested many times, prior to creating the screenshots and the results were consistent. What is in my screenshots are the MIDI commands being sent every time. This is what I expected, as there is no way to reprogram the MIDI Mongoose to send other commands. Those are the only commands it can send.


    I'm not 100% sure of how the MIDI programming works for the Kemper, but based on what I can do with a DAW, in Performance mode, you can:


    1) Change performances

    2) Changes current slot in your current performance

    3) Turn stomps on or off

    4) Turn post amp effects on or off

    5) Adjust values for effects


    I'm not aware of any PC or CC that could be sent that says "Add a new effect to performance 3, slot 1 into stomp 4, which wasn't saved as part of that performance." I could definitely be wrong on that, though.


    Even if that was the case, however, and there was a MIDI command I could send to invoke that behavior, then when you select stomp 4, it should say "Chorus" and not "Delay". Or when it happens in stomp two, it should say "Chorus" and not "Compressor". What the text says when you long-press the button not matching what is actually happening would also be a problem.


    I don't have another gig until next Friday. I may just try loading the most recent release-level OS onto the Kemper. Hopefully we will get a chance to practice before then, so I can test it out.