Can't rename rigs in Rig Manager - Version 3.2.37

  • I just updated Rig Manager to Version 3.2.37. When I rename the rig name, it lets me type in there like normal - but I can't store the rig. When I click 'Store Rig' the rig doesn't reflect the current date and goes back to the old stored rig name/date in rig manager.


    Is this a glitch others are having? Really frustrated with RM for the past year, it's always something messing up with one glitch or another, no matter the current version. Is there a contact of someone who actually updates software for Kemper I can make a ticket with so they fix it for future updates?

    Chris Spencer


    Kemper profiles of boutique and vintage amps will be available soon! Some of my gear:

    Hardware/Software -

    Adam monitoring, Pro Tools HDX 16x16, Pro Tools, Logic Pro X, BAE 1073 mic pres, Cascade Fathead Ribbon, SM57, various pedals

    Guitars -

    Duesenberg 49er, Fano JM6, Gretsch Tennesse Rose (w/TV Jones Classics), Nash Tele, American Strat (w/Lollars)

  • I just did some profiling about a week ago. I had a lot of issues with rig manager showing incorrect names and data in the fields. I kept unplugging the USB cable and letting my Kemper reconnect then it would show the correct names that I had typed in. That was happening to me a lot.

  • Hi,


    Also did happen to me.. on performance mode over right amps with other performance amps, changed alone the name of some rig performances, with this last upgrade my kemper became so slow... :( Not very happy indeed

    Mine looked like they were overwriting but after pulling the USB cable out and putting it back in and letting the Kemper reconnect I could see they were not overwritten. It seems to be more of a display synchronization issue for me.

  • Mine looked like they were overwriting but after pulling the USB cable out and putting it back in and letting the Kemper reconnect I could see they were not overwritten. It seems to be more of a display synchronization issue for me.

    Mine, even pulling the USB cable out and putting it back did not get back to original amp rig... I was making some changes and maybe meanwhile I saved it (the ones I want and the others that I did not want), can't remember..

  • I have never been able to rename a rig in RM past or present. I don't even know if you can. I have always renamed on the profiler screen and then the newly named profile propagates to the end of the list in RM which aggravates the hell out of me.

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

  • I have never been able to rename a rig in RM past or present. I don't even know if you can. I have always renamed on the profiler screen and then the newly named profile propagates to the end of the list in RM which aggravates the hell out of me.

    You can rename in RM and it is super easy. I have never had a problem with although I have had the issue the OP mentioned where the name looked wrong and looked like it had overwritten something by mistake but this has always been fixed by restarting RM to force it to sync properly.


    If you are unable to get RM to rename and need to do it on the profiler plug a USB keyboard into the back of the Profiler and just type the name into to the Profiler directly. It's a lot quicker and less effort than twirling the knob to find the right letter.

  • You can rename in RM and it is super easy. I have never had a problem with although I have had the issue the OP mentioned where the name looked wrong and looked like it had overwritten something by mistake but this has always been fixed by restarting RM to force it to sync properly.


    If you are unable to get RM to rename and need to do it on the profiler plug a USB keyboard into the back of the Profiler and just type the name into to the Profiler directly. It's a lot quicker and less effort than twirling the knob to find the right letter.

    That is basically what I am doing by pulling the USB cable. It forces a refresh of the connection to the profiler from the computer. It seems that may be a bit common.


    I never thought of plugging in a USB keyboard to the profiler and using that to type the name. That is a fantastic idea. That is the second really good idea I have picked up today from the forum.

  • I want to be able to right-click on the name in RM and type in what I want. I don't want to be plugging and unplugging a USB cable or a keyboard into the profiler. I already have a keyboard connected to my computer.

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

  • Is this just about the very latest RM version?


    I have 3.2.30.17230 from just before the newest version was announced and I seem to be able to rename Performances and/or the rigs in performances. The only thing odd I see is that until you click on one of the name fields, they don't look like editable fields.


    I select any performance from My Profiler or Local Library then click on the Name field in the upper right just below the "Performance Settings" header. The name is then editable and does not require any kind of save. I load other performances, change to Browse mode, restart RM, etc. and the renamed performances still retain the new names and work normally. Same thing for the names of the 5 rigs in the performances.


    Sorry if I'm misunderstanding something.


    BTW - working the same for Browser mode.

  • I am a dummy. I just figured out you can edit the name in RM in the right-most Description panel. I wish I knew that 6 months ago. :huh:;(

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

  • RM is also still having the problem where it won't save edited parameters I make to a given rig. Like I'll turn amplifier volume from 0 to 4, then save it. But I'll check that rig a few minutes later and the changes are gone and it's back to 0. Doesn't do this 100% of the time, maybe 1/3 of the time.


    It had this problem a few months ago, and I left the kemper/RM alone for a few months thinking a software update would fix this but it hasn't. Is there a particular previous RM software that's more reliable? I wanna say about 6 months ago the software worked fine, i can't remember which one that is.


    Another thought - i'm editing rigs in 'Local Library', they aren't saved on 'myProfiler' yet. Would RM work better with rigs that are on 'myProfiler'?

    Chris Spencer


    Kemper profiles of boutique and vintage amps will be available soon! Some of my gear:

    Hardware/Software -

    Adam monitoring, Pro Tools HDX 16x16, Pro Tools, Logic Pro X, BAE 1073 mic pres, Cascade Fathead Ribbon, SM57, various pedals

    Guitars -

    Duesenberg 49er, Fano JM6, Gretsch Tennesse Rose (w/TV Jones Classics), Nash Tele, American Strat (w/Lollars)

  • I am a dummy. I just figured out you can edit the name in RM in the right-most Description panel. I wish I knew that 6 months ago. :huh:;(

    Yes, this is the way to do it and even no STORE is required! You just confirm with ENTER on your computer keyboard.


    This is a transaction, that you can perform in the upper part of Rig Manager. You can change names of Rigs stored in your Local Library, which are currently not loaded in the edit buffer of a connected PROFILER. The lower editor part only works for the one Rig which is currently loaded in a PROFILER.

  • Is this a glitch others are having? Really frustrated with RM for the past year, it's always something messing up with one glitch or another, no matter the current version. Is there a contact of someone who actually updates software for Kemper I can make a ticket with so they fix it for future updates?

    chrisspenceratx

    I'm sure we can work on this with you, especially because it's working fine for us. Please open a support ticket on the Kemper website.

  • Yes, this is the way to do it and even no STORE is required! You just confirm with ENTER on your computer keyboard.


    This is a transaction, that you can perform in the upper part of Rig Manager. You can change names of Rigs stored in your Local Library, which are currently not loaded in the edit buffer of a connected PROFILER. The lower editor part only works for the one Rig which is currently loaded in a PROFILER.

    BayouTexan as well as the points Burkhard mentioned, another great feature that works without the need to save is the ability to rename fields in bulk/batches. For example if you want to rename all rigs with Amp Name as Fan to show Fender. Search for Fan highlight all rigs you want to change and type Fender into the amp name on one of them. All of the highlighted rigs will update and automatically save.


    The ability to update fields in bulk is a fantastic time saver 😁

  • BayouTexan as well as the points Burkhard mentioned, another great feature that works without the need to save is the ability to rename fields in bulk/batches. For example if you want to rename all rigs with Amp Name as Fan to show Fender. Search for Fan highlight all rigs you want to change and type Fender into the amp name on one of them. All of the highlighted rigs will update and automatically save.


    The ability to update fields in bulk is a fantastic time saver 😁

    That's great! Thanks! And I was just getting used to Mebo. ^^

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

  • Glad to be getting a lot of responses from my post, thanks to everyone posting:


    GmbH: I opened a support ticket and hopefully something on my end will get fixed, and/or software updates will have fixes.


    Everly - for me it's not just a display thing since my values on my kemper are unchanged too no matter if I unplug the USB cable and/or restart it.


    Wheresthedug - I'm aware of the USB keyboard trick to rename stuff..when I do that or edit on the unit itself with the knobs it still won't save the changes.


    Cmbrowns - I'm using the 3.2.37 latest Rig manager. But all these problems (unsaved name changes or paramater changes) have happened for the last couple software updates before that too...haven't had a reliable RM since late 2020. All my problems are happening in Browser mode, I haven't messed with Performance mode much.


    For everyone - All my problems are editing my rigs located in 'Local Library' - they aren't saved into 'myProfiler' yet. Would RM work better with rigs that are on 'myProfiler'? Can't imagine that would make a difference but that's a thought.


    Thanks again!

    Chris Spencer


    Kemper profiles of boutique and vintage amps will be available soon! Some of my gear:

    Hardware/Software -

    Adam monitoring, Pro Tools HDX 16x16, Pro Tools, Logic Pro X, BAE 1073 mic pres, Cascade Fathead Ribbon, SM57, various pedals

    Guitars -

    Duesenberg 49er, Fano JM6, Gretsch Tennesse Rose (w/TV Jones Classics), Nash Tele, American Strat (w/Lollars)