Rig selection "cross" skips down

  • I had read somewhere where there was an issue with the rig "cross" jumping performances. Normally I use rig manager or the foot controller so I never noticed before but when I push down, it will often skip a performance and then I have to scroll up one. Going up, it doesn't seem to skip, just down. I know that holding it down causes it to scroll so I thought I was holding it too long but I was pressing it pretty fast, not like your typical hold to scroll time. Perhaps the unit understands to scroll too quickly and skips one, because it wasn't doing it so much if I VERY quickly "pecked" the down button.

  • I'm sitting here in front of my PROFILER with current OS and don't experience such an issue other than that Performances can be skipped if the buttons get hold for too long. I tested with Rig Manager being connected and without.

    According to the changelog we fixed such an issue in OS 8.0.6. From that Thread it's not always clear, if users are really referencing the last OS version and the Rig navigation cross Up/Down buttons or external buttons....

    If you have that issue with OS 8.6.2, please open a support ticket and attach a PROFILER backup.

  • I did the most recent update just before this was happening. It is specifically and (for me) isolated to the rig navigation cross going down mostly. My belief is the unit goes into scrolling too quickly so a normal press get seen as a scroll request and it jumps one. I'll check it again to be sure but it didn't seem to skip if I pecked the button super fast, that's why I think that it goes into scroll mode too fast. I'll open a ticket and send a backup but I don't really understand how that will help if the unit goes to scroll too fast. That is the problem, not my rigs and performances.

  • I'm just wondering, if I send a backup, how is that going to help? Can the problem be in the file I send? I'll bet others are having this problem too, just like before. As I said, I'd look into the time the unit takes to decide to scroll. right now it seems like .1 second!

  • You are drawing generic conclusions testing with just one unit. That's always a long throw. I cannot reproduce the issue with multiple units and I'm not just pressing 0.1 seconds. Why would that software timing be different for your Down button compared to your Up button? Why did others report similar issues for the Up button and not for the Down button? These might be completely unrelated situations as we definitely fixed an issue in OS 8.0.6, which I had been able to reproduce.

    This could be a timing issue caused by data or perhaps that particular button is bouncing. That's what I would like to figure out. We cannot fix, what we cannot reproduce. And the reference is always current software.

  • I just noticed that when it skipped down, I only had to press up once and it went to where I wanted in the first place thus the comment that it worked OK up and not down. Either way, sounds like nobody else sees it and it's not that big of deal, but I assure you I am not imagining it. I'd be glad to do a video.

    Before the "fix" you wrote "I cannot reproduce such behavior with current OS and my data at all" when many users were having the problem so you could be drawing conclusions that it was actually fixed this time. Everybody makes mistakes. Just saying.

  • The point is, that we fixed an issue. I know it, because I had verified it at that time. I had been able to reproduce an issue with the revision before and I was not with the new revision including a specific software change to address this behaviour.

    If you now experience a similar issue with the latest OS - which I don't question - the conclusion that this is the same issue that we had before is not obvious. Especially if I can still not reproduce such an issue. Headache is not always caused by the same desease. It's also not clear, why you experience this constantly but just with the Down button, others had reported it for the Up button, and some don't seem to experience it at all. This has something to do with timing, but we don't know which component triggers it.

    This requires more analysis. That's why I requested a backup to check, if I can reproduce your scenario with your data and outrule data having an influence. Referencing the other thread is not sufficient, because that lead to the fix we already got.

    I also would like to know, if you experience a similar issue using the Down button in Browser Mode.

  • Thank you. I will check it out better tonight and do a more detailed study as well send in a backup along with the exact problem.

    When I was first seeing this I was trying to get some work done so I really wasn't concentrating on exactly when or what was causing the skip, I just kept working around it. Like I said if I recall, if I pecked it VERY fast, it didn't skip but I need to verify that. Anything longer than a very fast peck skipped one, and I'm pretty quick with the fingers8).

  • If this was just a button thing, I would expect something similar in Browser Mode for example stepping through the characters of Sorted by Name.

    If it also had a "hold to scroll" function there also, presumably yes unless there was a difference in the time in browse the unit takes to go into scrolling mode. It seemed very fast in performance mode as I recall but will confirm. I still have a hunch that is the issue.