Updates Almost Never Work [solved] - Antivirus

  • I'm getting pretty sick of dealing with Kemper updates. Every time I get a pop up saying that a new version is available, and I accept it, Rig Manager says it can no longer connect to the profiler. This is an ongoing issue. Right now I have the latest OS 8.7.1, but when I download Rig Manager 3.2.73 it says Rig Manager cannot connect to the profiler..check yada yada yada. This is BS. I upgrade plenty of programs such as Helix, Izotope, ToonTracks, Waves, ILock, etc, etc, and this is the only software that really sux. I love the Profiler, but the update system is the worst. I had to do a system restore on my PC to get the old Rig Manager version working again..3.2.57. No amount of rebooting, turning the profiler on and off countless times does anything...ugh!!!! And this has persisted through Win 7, 10, and now 11. The only real update I was able to get was the last one where the Profiler, and Rig Manager updated at the same time, but here I am again.


    .kemper-amps.com/wbb_suite_3/index.php?attachment/16417/

  • The Profiler is up to date. It's Rig Manager that once updated does not connect to the Profiler. I did a system restore on my PC and got the older version (3.2.57), and it works again. But now, the pop up for the newer version of Rig Manager keeps appearing telling me to upgrade...and if I do, I know it won't work again. This is a serious software issue that needs to be resolved.

  • No one else is having an issue with the current RM. You can't expect Kemper to resolve an issue that only one person experiences, but the user might be able to. According to Kemper, you should be using RM 3.2.70 for OS 8.71. In RM, go to >File >Preferences > and uncheck "include Beta Test release". You will only be notified of Full Public release versions.


    PROFILER Operating System 8.7.1 Release for all PROFILER models

    USE THIS OS VERSION FOR ANY PROFILER™ MODEL

    Rig Manager 3.2.70 for Windows® / macOS® and 1.2.0 for iOS® required!


    PROFILER Stage™ users can immediately upgrade to this revision regardless of their current OS!

    To upgrade PROFILER Head™, PROFILER PowerHead™, PROFILER Rack™, and PROFILER PowerRack™ via USB memory stick from OS versions before OS 7.3, OS 7.3.2 needs to be installed first! Older versions than OS 7.3 on these models don't recognize this new integrated OS revision. For this purpose OS 7.3.2 can be found on the Download Page at Older Software Versions:

    https://www.kemper-amps.com/do…8/Older-Software-Versions

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

    Edited 3 times, last by BayouTexan ().

  • I'm getting pretty sick of dealing with Kemper updates. Every time I get a pop up saying that a new version is available, and I accept it, Rig Manager says it can no longer connect to the profiler. This is an ongoing issue. Right now I have the latest OS 8.7.1, but when I download Rig Manager 3.2.73 it says Rig Manager cannot connect to the profiler..check yada yada yada.

    Please contact support by using the contact form on our website.

  • I would be hacked off too in your shoes but I can honestly say I have never had an issue like this in all the time I have owned my Kemper. As noone else seems to be having similar problems it would suggest that the issue is something else in you system causing a conflict rather than a problem with the Kemper updates. I would take up Kemper’s offer of help via the support channel to have them look at your own case.


    Hope you get tor the bottom of it soon.

  • Well, thanks for all the positive support there guys. To those that are saying no one else is having this issue, please google,"Rig Manager cannot connect to profiler", and see the multitude of posts. Maybe not so much the new RM version as previous versions, but it's out there. Thank you for the online support link, maybe that will get me somewhere. Version 3.2.57 of RM is working fine with Profiler OS 8.7.1

  • Well, thanks for all the positive support there guys. To those that are saying no one else is having this issue, please google,"Rig Manager cannot connect to profiler", and see the multitude of posts. Maybe not so much the new RM version as previous versions, but it's out there. Thank you for the online support link, maybe that will get me somewhere. Version 3.2.57 of RM is working fine with Profiler OS 8.7.1

    I did, and found a multitude of 3 people having problems with RM connection going back 3 years. The are quite a few posts of people helping those 3 get connected though. ;) I'm glad it's working for you. Cheers!


    Kemper Stage - Can't connect to Rig manager?


    Rig manager not connecting to my profiler


    rig manager doesn't show my profiler


    (I omitted the last result since it is from a post from 2016 and not relevant anymore).

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

  • Dude, you seem to be going out of your way to dismiss the problem rather than help..Kemper Employee? Super Fan Boy? Keep your condescension to yourself.


    Guess you missed this one.

    Rig Manager does not connect with Kemper with latest Update


    Guess you also missed this one.

    Rig Manager no longer recognizes the profiler (after RM update?)


    It didn't take that long to find multiple people experiencing the same problem..these threads are from 2020., which is how long I've been having issues.


    When RM announces that an update is available, and I click download, I expect it to work after the update. Not give me a complete hassle, telling me to check my USB connection, or make sure I have the latest Profiler OS. The Kemper is an amazing piece of gear, but the software is lacking in some areas.

  • Well, thanks for all the positive support there guys. To those that are saying no one else is having this issue, please google,"Rig Manager cannot connect to profiler", and see the multitude of posts. Maybe not so much the new RM version as previous versions, but it's out there. Thank you for the online support link, maybe that will get me somewhere. Version 3.2.57 of RM is working fine with Profiler OS 8.7.1

    And thanks for the sarcastic response.

    Why did you post in the first place? The assumption is you are looking for confirmation that there is a problem - hence why many are writing back to say, not seen that issue to try to assure you its not that widespread. Are you only looking for others to post that they have seen the problem? Sorry, haven't seen it...


    I am aware that connection can sometimes be hit and miss but not related to an update.


    So, contact support and hopefully they can resolve it.

  • Dude, you seem to be going out of your way to dismiss the problem rather than help..Kemper Employee? Super Fan Boy? Keep your condescension to yourself.

    But I did offer help and told you how to remove notices of beta updates... and Yes, I am a fan of Kemper products!

    In RM, go to >File >Preferences > and uncheck "include Beta Test release". You will only be notified of Full Public release versions.

    You also asked us to google for posts, and I did that for you...

    To those that are saying no one else is having this issue, please google,"Rig Manager cannot connect to profiler", and see the multitude of posts. Maybe not so much the new RM version as previous versions, but it's out there.

    Maybe change your title from "Updates Almost Never Work" which is untrue for the vast super majority of users to "Need Help Connecting RM"


    Cheers!

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

    Edited once, last by BayouTexan ().

  • I hope you get yours sorted. I'd be pissed off and scratchy too if it kept failing for me.


    I'm assuming you've got Windows update running and are usually pretty up to date. Thankfully I'm also not one of the many people suffering from this. My updates just work.

  • Ha! In the spirit of helping others out, I will post the solution. After reading many more threads where RM was not connecting after updates, I have discovered the problem. In one thread, the poster said he clicked "Update Driver" in Device Manager on the Profiler icon, and that took care of his problem. When I looked, there was no driver, and when I clicked update, it said there were no drivers available?


    So, I deleted RM (again), and it's associated files, turned off my antivirus, and reinstalled RM 3.2.72.....and it works! I have the latest OS, and RM working. The anti virus has been the main culprit over the last couple of years, blocking the driver from installing.


    :):):):):):):):):):):):):):):):):):):):):):)8):!:

  • Glad to hear you got it sorted and thanks for sharing and this will hopefully help others.


    It does also confirm the issue wasn’t that RM is a useless piece of crap as your initial post suggested though. Instead it was something else in your system (in this case over zealous antivirus software). This is actually what myself and others were trying to say right from the beginning. Merely, that you might be looking in the wrong place for a solution and trying to guide you towards finding the real source of the problem. As none of us know your exact system we clearly can’t know what your own issue is but can hopefully guide you to start look in the correct direction.

    I would be hacked off too in your shoes but I can honestly say I have never had an issue like this in all the time I have owned my Kemper. As noone else seems to be having similar problems it would suggest that the issue is something else in you system causing a conflict rather than a problem with the Kemper updates. I would take up Kemper’s offer of help via the support channel to have them look at your own case.


    Hope you get tor the bottom of it soon.

    The fact that so many others merely confirmed they don’t have problems isn’t evidence of a cult trying to protect their “uncle’s company” but just people trying to provide evidence that the issue is not RM based but wider system based. I would be frustrated in your shoes too (we all would) but nobody here was trying to discredit you.


    Anyway, glad to hear all is well now. 🤘

  • DonPetersen

    Changed the title of the thread from “Updates Almost Never Work” to “Updates Almost Never Work [solved] - Antivirus”.