Reamping - S/Pdif issue….once again

  • Hey good people. I’m very embarrassed to admit that yet again I struggle with reamping through S/Pdif. I’m just not good friends with the reamping game apparently.


    My Kemper settings:

    Input: S/Pdif input Reamp

    Output: Git/Master mono

    Freq: 44.1kHz


    My DAW: Cubase 10

    DI track: Output set to S/Pdif left

    Track for reamping: Input set to S/Pdif Right and output set to Master Out in Cubase.

    Freq: 44.1kHz


    Interface: Babyface Pro FS

    Windows 10

    S/Pdif cables both correctly connected.


    What I read from the manual the left side carry the DI signal and the right side carry the reamped signal. So I guess my input/output choice on the tracks in Cubase are correct.

    When I hit play I see the volume meter bouncing on the DI track. But there’s no sound. The track for reamping is armed for recording. And it doesn’t matter if I have the monitor on or off on this track. If I press monitor on at the DI track the volume meter stops bouncing. I cannot hear either the DI signal or the reamped signal. The reamped signal does not enter Cubase.


    The S/Pdif connections are fine. I can record both the DI signal and the distorted signal at once.


    What the heck am I doing wrong?

  • The SPDIF input must carry the DI signal into the Kemper. (The DI is in mono but you can reamp it outward in stereo as an option in the Output Settings). The Kemper Input Settings on Page 1 must say Input Source - SPDIF Input Reamp. So, you need to set that every time you reamp and then return it again to Front Input to play your guitar.


    I think your routing is not correct. Don' think of SPDIF as left and right, think of the two cables as IN and OUT. SPDIF In to Interface is your guitar and/or DI. SPDIF Out is the DI signal going back to the Kemper to get amped which goes back to the interface. It's easy for me to think of it as a loop.


    Check out my tutorial. Even though it's for non-SPDIF reamping, the settings are similar and it has some comments on using SPDIF.

    How to Reamp Kemper with Reaper (non-SPDIF Method) Tutorial..

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

    Edited once, last by BayouTexan ().

  • Hey man 🙂


    The input is already set to “S/Pdif reamp input” for this purpose.


    I only refer to Left/Right because the manual wrote it that way. When I record both dry and wet signal through S/Pdif (Git/Stack) it must be viewed as two inputs, right? So I basically just look at them as two channels that can do both two ins or in/out.


    I select the output of the DI track as the S/Pdif 1/Left. As I see it on YouTube and in the manual, that is correct.


    I select the input on my track for the reamped signal as S/Pdif 2/Right. Again it’s what I see on YouTube must be done. And I believe the manual says the same. So my routing must be correct 🤔 It’s the same as saying, what you’re saying. You just call S/Pdif In and S/Pdif Out instead.


    In fact….I’ve tried reversing it many times as well. I just didn’t mention that, because I think that I have it right.


    Last time I used the reamping feature, I used my old audio interface and it worked. Now it doesn’t. But since I can record both clean and dry signal at the same time through S/Pdif guitar/stack, I would think that the new interface works fine and it’s a matter of me overlooking something.

  • I'm a bit confused. Is it when you want to reamp the DI track you have problem or is the problem when you record and want a DI track at the same time? :wacko:

    Think for yourself, or others will think for you wihout thinking of you

    Henry David Thoreau

  • Are you sure you are routing the DI signal to your Kemper?

    The fact that the DI meter turns on in your DAW just means the track is being played back, not that it is being actually sent to your Kemper. Does the If the KPA Input LED is not turning on, its not gettting any juice ;)

  • From what I can understand, it sounds like you have to convert the SPDIF DI signal back to an Analog signal for the reamping to work. I don't know if Kemper does this conversion automatically from the SPDIF Input when selecting reamp in settings. This might be where you are having problems. I use an Insert plugin in my DAW to convert the digital DI signal back to Analog and then send it back to the Kemper.

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

  • No

    So the reamp takes a digital signal? I can take a DI wav file from, say a cell phone, plug the cell phone to the Kemper Return and it will reamp that (for non-SPDIF reamp method)? Or take a DI wave file and cell phone connected to the SPDIF in and it will reamp that one for SPDIF method?

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

    Edited 2 times, last by BayouTexan ().

  • Are you sure you are routing the DI signal to your Kemper?

    The fact that the DI meter turns on in your DAW just means the track is being played back, not that it is being actually sent to your Kemper. Does the If the KPA Input LED is not turning on, its not gettting any juice ;)

    That’s true. I had some routing issues because I didn’t quite understand the RME software. But I got some help from ‘lightbox’ and got that sorted out. Still issues though.

  • Once I update my interface with SPDIF, I will definitely make a reamp tutorial "with SPDIF" in DAW because it is no doubt confusing.

    The more you find what Kemper can do then the harder you try to find what it cannot do -- like make a good cup of Frappuccino.

  • Once I update my interface with SPDIF, I will definitely make a reamp tutorial "with SPDIF" in DAW because it is no doubt confusing.

    That would be cool. I think we kinda found out, that what my problem might be. The LED of the physical input and the LED of the physical output are always lit. Playing or not playing. That might mean something is going on.