HD500 as midi controller

  • After upgrading to newest firmware my Midi controller isn't triggering the X slot at all. I have my patches set to CC#22 but nothing- sucks because it's my boost & have a gig soon! Switched it to CC#23 & still no luck.


    I'm noticing that the HD500 isn't toggling the corresponding stomp like it should so thinking bug could be there? Sucks because it worked flawlessly before- thanks for any help!

  • hey lef, I am not sure about Browser mode. I want to say I've heard talk of it being done but cannot find the specific means to do it. But the MIDI manual does have this:


    CC# 48 (Performance Mode only)
    Increases performance index. Value triggers two different modes:
    * Value 0, increase performance n to n+1
    * Value 1 initially increases performance by 1, after a timeout the Kemper Profiler starts to scroll performances upwards. Value 0 stops scrolling.


    CC# 49 (Performance Mode only)
    Decrease performance index. Value triggers two different modes:
    * Value 0, increase performance n to n-1
    * Value 1 initially decreases performance index by 1, after a timeout the Kemper Profiler starts to scroll performances downwards. Value 0 stops scrolling.

  • Has someone found a way to use the HD500 for browsing the Kemper Profiles ? I mean, doing as if I press the RIG buttons of the KPA


    This functionality is not implemented (yet?). You may use a double momentary switch to switch through profiles. Set the switch to Rig Up/Down.

  • I just made a preset & an entire Setlist (to save you time) plus an overview video. Basically, I am able to turn all Stomps & FX on/off & also have access to MIDI locations 1-64 on the Kemper (which is more than I need!). Also, I can either plug a guitar directly into the Kemper or go through the HD500 & control/power my Variax plus plug in another 2 instruments (I then send a direct signal from the HD500 to the Kemper) - and I have Volume & Expression pedal control. (Oh, also no mismatched LEDs for stomps/fx)


    Link to files and video:


    https://www.dropbox.com/sh/wkc…dzafVs47jWRzC5JfCx5a?dl=0

  • I just made a preset & an entire Setlist (to save you time) plus an overview video. Basically, I am able to turn all Stomps & FX on/off & also have access to MIDI locations 1-64 on the Kemper (which is more than I need!). Also, I can either plug a guitar directly into the Kemper or go through the HD500 & control/power my Variax plus plug in another 2 instruments (I then send a direct signal from the HD500 to the Kemper) - and I have Volume & Expreesion pedal control. (Oh, also no mismatched LEDs for stomps/fx)


    I have rather similar setup, in addition I have set the HD500 Looper switch as KPA TUNER on/off for all presets and Tap controlling KPA's TAP, naturally ;)


    I have set the Volume pedal range alternating between rhythm/solo levels as 0..max was too drastic and difficult to adjust just slightly.


    HD500 expression pedal's Toe switch controls different things for different profiles. Many times it just turn wah on/off, but in sometimes it may on/off other effects like Vibe, volume boost or tremolo.

  • I just made a preset & an entire Setlist (to save you time) plus an overview video. Basically, I am able to turn all Stomps & FX on/off & also have access to MIDI locations 1-64 on the Kemper (which is more than I need!). Also, I can either plug a guitar directly into the Kemper or go through the HD500 & control/power my Variax plus plug in another 2 instruments (I then send a direct signal from the HD500 to the Kemper) - and I have Volume & Expreesion pedal control. (Oh, also no mismatched LEDs for stomps/fx)


    Link to files and video:


    https://www.dropbox.com/sh/wkc…dzafVs47jWRzC5JfCx5a?dl=0


    Wow!!! Thanks for that video. I am seriously considering this option over the remote at twice the cost (and having a backup from the HD500). I saw someone mention the HD500 vs the HD500HDX (I don't know the acronym.....an updated version) as the ideal usable one....is there something additional I need to know?


  • I have the HD500, the HD500X is the latest version. It really depends what you're looking for as to which one you decide on. The MIDI capability of the HD500 is enough for me - of course, I already had it & replaced it with the Kemper.

  • Hi all,


    I’m new to Kemper AND midi (and this forum).


    I’ve successfully connected my POD HD500X to my Kemper Profiler via MIDI. I can change rigs in my Kemper without any problems.


    I’ve setup the POD HD500X foot switches (FS1 through FS4) to control the Kemper’s Stomp boxes A-D. I setup the POD HD500X foot switches (FS5 through FS8) to control the Effects (X, Mod, Delay and Reverb).


    I can successfully turn on and off my stomps and effects on the Kemper through the POD HD500X.


    I set up some effects in my POD HD500X so that when I click a foot switch, it lights up on the POD HD500X.


    (A quick note here, I’m plugging my guitar straight into the Kemper, I’m only using the POD HD500X as a midi controller.)


    Now when I turn on the FS1 switch on my POD HD500X it lights up the FS1 switch on the POD HD500X and it turns on Stomp A on the Kemper. When I turn off the FS1 switch it turns off the light on the FS1 switch of the POD HD500X and it turns off Stomp A on the Kemper.


    I’ve matched the stomp and effects settings for my rigs on the Kemper with presets in the POD HD500X. This means when I change Presets on my POD HD500X to change to the Rig on my Kemper, the stomps and the effects in the rig on the Kemper match with the foot switches in my Preset on my POD HD500X.


    I can then properly control all the stomps and effects on my Kemper through my POD HD500X.


    So far so good…


    When I use the POD HD500X to bring up a Rig (let’s call it Rig 1). Let’s say stomp B was off when I saved the Rig 1 profile on the Kemper. If I turn on FS2 (which turns on Stomp B), FS2 lights up, Stomp B turns on. Everything is good.


    If change Presets on the POD HD500X to go to another Profile/Rig then come back to Profile/Rig 1, FS2 is still lit up on the POD HD500X, but stomp B is off on the Kemper. When I turn off FS2 on the POD HD500X, stomp B turns on. A bit baffling…


    After an hour or so of experimentation and a bit “googling” I’ve come to the following understanding:


    In the POD HD500X in the MIDI ASSIGN Screen you set your MIDI Channel to “01”; the Message to “CC Toggle”; the CC # to the proper number for the needs of Kemper (“17” for Stomp A, for example); and a MIDI Value of either 0 or 127 (off or on).


    When you save the Preset in the POD HD500X those MIDI settings are saved. When you turn a foot switch on or off, the MIDI value changes from 0 to 127 (or vice versa). Of course your foot switch light turns on and off as well.


    If you change presets on the POD HD500X it tracks the last setting of your foot switches, so when you come back to the Preset the foot switches are all turned on or off accordingly, BUT it does NOT track any of the MIDI Assignment Values (0/127 – on/off). When you come back to a Preset, the MIDI assignment Values you set when you last stored the Preset is what is sent to the Kemper (or any MIDI device connected to the POD HD500X).


    This means when you create a Preset in the POD HD500X where FS1 is off and the MIDI assignment Value was 0 (off) these settings both match and everything is copasetic. If you turn FS1 on, it turns the MIDI Assigned Value to 127 (on) and sends it to the Kemper. This is good.


    However, if you then leave the Preset in the POD HD500X and come back to it later, your FS1 will be on (because the POD tracks that), but your MIDI Assigned value will be 0 (off) – because the POD does not track that. When you turn off the FS1 switch it will change the MIDI assigned value to 127 (on) and send it to the Kemper. This is bad.


    Most annoying and a tad frustrating. Nice way to spend a Saturday morning.


    If I’m wrong, someone please tell me.


    I’ve had the Kemper for about a week and totally love it. What an amazing product!! It has exceeded all my expectations – and I had very high expectations.


    The problem I am having has nothing to do with the Kemper and everything to do with the POD HD500X (or my lack of understanding).

  • Thank you! Unplugging the USB worked!


    I always used the Line 6 Edit (it's nice software). I never considered this possibility. Now when I switch Presets on my POD, the default stomp and effects settings for my Kemper Rig light up my POD foot switches. Which is how I would expect it to work.


    I really appreciate your response!


    Turns out it was my (ID ten T) error. It usually is. :|

  • A quick follow up. It appears that it's not the fact the POD has the USB connected, it's when the Line 6 Edit software is running.


    I plugged the USB back into the POD and my computer (my POD HD500X Edit software was NOT running) and everything worked properly. When I started the Edit software I ran into the problem.


    I exited the POD Edit software (while leaving the USB plugged in) and all was fine again.


    So the POD Edit software seems to affect the communications of the MIDI assigned value to the Kemper. Interesting.


    Thanks again.


    Jay

  • I was getting ready to buy the KPA Remote, but after looking this over and some other videos I think I will go this route. Easy programming and an exp. pedal. The FCB will be leaving and the 500 will be utilized. Thanks for the info.