Posts by jmjewell

    Got the call today from the repair shop. Not what I was expecting. I dropped it off yesterday afternoon and by about 10am this morning they were calling me to come back and pick it up. Turns out that the main board had to be replaced. It was not covered under warranty as it was past the window. However, it was a $100 fix. What a relief!!!! I just knew I was going to be buying another controller and dropping about $500 right before Christmas...… I have to give a shout out to the repair shop in Nashville, TN(don't know if it's a forum no no to state their name). They jumped all over this and I am very happy with their service and $$$$. Their tech even gave me a receipt with a notation stating the original serial number of the original main board in case I have any other issues down the road. These guys are TOP NOTCH!!! I highly recommend them if you are in the Nashville area. If anyone needs a good repair shop in the Nashville area, contact me and I will be glad to hook you up with this repair center.

    Searched the net and found a certified repair center for Kemper about 1 1/2 hours from my home. I took the Kemper and the controller to the repair center and plugged my profiler up to one of their controllers and it worked. Then I plugged my controller up to one of their profilers and nothing..... It's something going on with the foot controller. Also, we used my cable to hook this up at the center. I'm hoping its just a short in the jack and nothing more serious. Sure would be nice if Kemper would cover this under warranty. Its a few weeks out of warranty but this thing is like brand new. It hardly ever leaves my house and it has not had any wear and tear on it. Not sure what it will cost to repair it, but I know this repair center offers a mod where they replace the jack in the back of the profiler to a locking style jack like the jack on the controller. They charge $250 to do this so I'm expecting this to get a little pricey. If its going to be that much, I think that I would rather pay a little extra and just get a brand new controller???? Any thoughts or advice??

    I have had my Kemper toaster and controller since mid October of 2016. Never had any issues until last night. I powered up and the controller is completely dead. I double checked the contrast to make sure I wasn’t overlooking anything obvious. My next step was to change the Ethernet cable. I tried three different cables, all of which show good on a tester. I have powered off and on several times with no luck. I noticed that from the menu of the toaster my expression pedal that is plugged into the controller does not show up which makes me think that the profiler is flat out not communicating with the controller. The same expression plugged directly into the toaster shows up and functions as expected. As a last ditch effort I stuck a thumb drive in and updated the firmware. Still not getting any lights on the controller at all. I am about 3 to 4 weeks past the 3 year warranty......... I’m starting to think that there is a short in one of the Ethernet jacks. Before I take this to the local repair shop does anyone have any ideas what may be causing this to happen out of the blue???? Are there any controls in the Kemper that could disable the output of the Ethernet jack for the controller?