Posts by Aloof01

    Thanks but it's still not working on my mac (OS Catalina). RM crashes as soon as I plug my Kemper...

    Good news ! It now works !

    The Kemper dev team inspected a backup of my Kemper and identified a couple of defective rigs. I erased them but RM was still crashing. I then erased all my rigs except the favorite (and I was ready to go all the way and erase everything!) and that did the trick ! Was there more defective rigs in the lot ? I don't know but the main thing is that it now works !

    Thanks to all that expressed concern and thanks to the Kemper dev team !

    And now, let's edit !

    It would help the Kemper team if you indicated what computer you have os 10.15.1 and 10.15.2 installed on. Is it an iMac, Macbook pro, Mac Mini, hackintosh? That could explain why some people have no problems with RM beta using Catalina (10.15).

    MacBookPro9,2

    Dual-Core Intel Core i5

    2,5 GHz

    OS Catalina 10.15.1.


    Nothing, most probably. There were three different issues that could cause a crash on startup. Only two of them have been fixed in the latest beta. If you haven't done so yet, please send a crash report either via the Rig Manager feedback function or by opening a support ticket.

    I opened a ticket after the first Beta. I'm opening a new one now.

    Thanks for your concern, guys.

    Thanks but it's still not working on my mac (OS Catalina). RM crashes as soon as I plug my Kemper...

    Look at you being smug about it. I have a MacBook with the latest OS and it still doesn't work, so.... you know.

    Updated today (unwillingly) to mac os catalina. Re-installing rig manager did not help. Neither an update of xcode to the newest version did help. Nor deplugging all devices and bundling it with plenty of restarts.


    Rig Manager still does not want to run on my machine.

    Same here (and I'm not that happy about OS Catalina either, GarageBand not working anymore - will have to fix that later). RM crashes as soon as I plug the Kemper into my MacBook. I've tried several things, even chanting mantra, but it still doesn't work. So frustrating....

    Can you guys be more specific what you mean when you say it crashes? Did the program quit/shut down, or did it just sit there saying it was trying to sync but no progress?
    I am on Mac using OS 10.13.6 When I first downloaded Rig Manager and plugged in my Kemper with USB it tried to sync and just sat there not updating any synced rigs. I just unplugged the USB cable from my Mac and the plugged it back in and the sync worked very quickly, no issues since.

    I always start my Mac first, then start Rig Manager and THEN plug Kemper into my Mac.


    Also try a different USB cable and make sure you are using the correct USB out on the Kemper .

    I have tried every possible way. I even updated my mac to OS Catalina 10.15.1 !

    Installation of both RM 3 and KAOS 1.7 goes fine. Then when I plug the Kemper into my Mac, RM shows a window saying "syncing" and then crashes immediately, while the Kemper continues trying to sync without moving.

    Hi guys, anyone experiencing a failure when trying to connect with the New Beta Rig Manager?

    The moment it starts synching Rig's, Rig Manager bombs out.

    Any help?

    Yeah I had the same issue. RM 3, Kemper OS 7.1.7, Mac OS 10.12.6. As soon as I hooked the Kemper to the computer RM tried to sync and crashed instantly.

    I did a system reset, tried again. At first it looked as is was going to sync but then it crashed and kept crashing ever since. Back to square one. Doesn't work.

    Same thing just happened to me too !

    Okay, so that's it, I finally got it to work !

    And all this time it was just a simple thing that I wasn't doing right !

    I got this answer from Kemper support : "May I ask, if you are aware, that you have to save this setting and load that Slot afterwards. So you need to switch to another Slot and return to this Slot to send the program change."

    Well, no, I wasn't aware of that !

    So thank you everyone for your help, in particular DamianGreda , Kemper support and Andrew from Meris who took it upon him to film a step by step guide on how to hook up a Meris pedal via Midi for me.

    No, it's Midi fun !