Spillover for effects loop in X slot when changing slots

  • I use an eventide H9 in the effects loop in the X slot. On all my Rigs in performance mode, I keep the X slot for use with the effects loop. but in most slots I keep it saved as bypassed. Thus, I'm not using the loop in most of my slots, but always can go to it if I like, since the loop is simply bypassed. While the kemper handles the spillover fine when bypassing the loop, or even changing rigs with to another rig with the loop default on, not so when I switch to a rig that has it bypassed. For example, if in slot one I have the loop on in the X slot using an H9 delay, and I switch to slot two with the loop bypassed, (though still assigned to the x slot) the delay doesn't spill over. This is an inconvenience, since I'd like to avoid doing a double step each time.


    This seems like something that could be an easy fix since the KPA can already do effects loop spillover from one slot to another.
    Yes, I know that I could simply send midi messages to the H9 including off and then simply leave the loop on both slots and I in fact do that sometimes. However, I have a couple performances in which I leave midi settings blank, so that I can use various delay and reverbs presets on my H9 on the fly, in which case pre-programed midi messages won't work. So I send no messages on these performances and change presets on my H9 manually. This feature request would also be useful for those using non-midi capable delay effects in the loop.

  • I solved this issue. Turns out the Kemper already does this. The issue is with my Eventide H9 more or less. Suppose you have two Rigs in a performance, both of which you'd like to use the same effect our your external effect, in my case the H9. Therefore, both rigs are sending the same midi PC to my Eventide.


    Therefore, if you are already on a Rig that's utilizing that particular preset in the H9 and go to another rig: if that new rig also sends the same midi PC to the H9, the H9 doesn't simply ignore it since it is already on that preset. Rather, the H9 resets, cutting off the delay trail and starting over.


    I just assumed that the Kemper wasn't allowing the spillover, but rather the H9 was being reset. The way to workaround this is to do a bit more planning when arranging rigs. If you need to keep the spillovers going, you'll need to make sure that you send the PC message only to the first Rig if the next Rig you select you want to utilize the same H9 preset. Otherwise, if the H9 receives the same message twice it will reset the effect, cutting off the delay trails.