We still cannot update over usb?

  • Updating through Rig Manager is how I've done it for at least the last year. It's been available for quite some time, although it used to be inconsistent. Not anymore (for me, anyway).

    Shouldn't be a problem.

    EDIT: I misread your post. Somehow I missed that you tried using RM and it failed. Restarting (as suggested below) is one idea. I'd also consider a support ticket. RM has been stable for updates for a while, so they may have a fix.

    “Without music, life would be a mistake.” - Friedrich Nietzsche

    Edited 2 times, last by Ruefus ().

  • I had this problem with the latest update too, it was the first time an update over usb didn’t work at the first try. A reboot of my computer (MacBook Pro) did the trick, though! Have you tried turning it off an on again?

  • I've done all the recent betas and releases with the USB method and I'm using the new M1 Mac, which for all its strengths is not yet quite reached the fully supportive status in the world of compatible software, as it's so new. I always do a USB backup first before an update. That way, should anything wonky occur were I to update the firmware through Rig Manager or USB, I always have my latest backup on the USB. Since I've been successfully updating betas and releases all the way back to 2. whatever 8 years ago or so, I've seen no need to change to the Rig Manager. Actually one of the three times I updated that way, it crashed and I just went back to the perfectly fine USB method. Dragging the file onto my USB and physically plugging it in the KPA adds about 30 seconds extra work to updating, and it isn't like I update more often than a half a dozen times a year.

  • I will try the reboot just incase. It has never worked for me. Can someone tell me how it should be done? Maybe I am flat out doing it wrong

    What firmware are you on?

    Which Rig Manager version are you using?

    Does the rig manager or windows even recognize your profiler as a device?

    My procedure would be:

    Hook up the profiler via USB, Start Rig Manager, see if it recognizes the profiler as my device, push the "search for updates" button (on my Mac it's somewhere else, but the procedure should be the same), start downloading the update

  • I on the last official release before all the fuzz betas started. I updated my rig manager to the latest one first It says I need a new fw version but when I have it check for more FW it never does anything else

  • I have found that if Rig Manager will not see the Kemper, if I unplug the USB cable on the Kemper end and reconnect, Rig Manager will then see the Kemper. Unplugging from the PC side does nothing. This may help you connect to Rig Manager better

    I also usually have to reboot my PC after installing a new version of Rig Manager before installing a new version of firmware. If I don't I usually get an error message with a failed to install.