My Kemper is reeeaalllly slow

  • Hi Guys,


    My Name Is Rabea, I have recently got a Kemper Rack Amp, and it's been amazing up until the other day, when i noticed the screen on the remote looked glitchy, i thought the display had frozen or something so switched patches and then noticed the whole unit, including the rack amp was suddenly really slow.


    I switched it off and left it a couple of days, then tried it again and it took forever to boot up, leaving me on the startup screen for about 20 mins. I rebooted from USB with the latest OS (i even tried The BETA 5 version) and so far nothing has worked.


    It loads up after about 10 mins, and then when i try use any features, it takes about 6-7 seconds to do anything. The remote just doesn't work at all not, it lights up and then basically goes to a blank screen and the LED's go off.


    Help would be amazing if anyone knows how to fix this.


    Cheers

  • Hi Rabea, the warmest welcome at the Kemper forums.


    I always enjoy your video appearances immensely.


    As it's difficult to troubleshoot your problem from here I suggest to open a support ticket (see my sig).
    You'll be up and running very soon.

    Thanks man,. I appreciate that a lot! i hope it can be fixed, any ideas as to what they will do?

  • Welcome, Rabea!


    Unless someone else here has experienced very-similar or the same behaviour of his or her board, and I've not seen anything thus far IIRC, I doubt we'll be able to help. I mean, last-resort fixes for the Kemper itself in these parts usually involve force-installing firmware, resetting the unit and so on, but I know of no way to do this for the remote.


    That said, I'm guessing (and hoping) that the boffins at support might be able to guide you through some sort of procedure that resets it. As things stand, I've not heard any hint that this might even be possible, but you never know.


    Failing that, one can only assume you'll be looked after through a replacement unit. Bummer man. At least you can rest assured that this sort of thing is so rare that I, at least, haven't heard of its happening.


    Love your playing and the passion you show, by the way! Good luck with it man.


    PS: I wonder if it's possible there's a faulty battery in it. I've not heard any mention of one here on the forum, but I s'pose there's an off chance there's one in there somewhere.

  • In the meantime, try booting the Kemper without the Remote connected. A dodgy cable can cause the Remote to reset itself continuously, which might also make the Kemper stall as its waiting for reconnection/resyncing. Worth a try anyway.

  • OK - so i tried all of the above, i've sent a support ticket too. I tried refreshing the whole thing, starting a new, this morning i received this message.


    "DSP Communication Error"


    I think it's safe to say my lovely new Kemper is indeed, F****D

  • OK - so i tried all of the above, i've sent a support ticket too. I tried refreshing the whole thing, starting a new, this morning i received this message.


    "DSP Communication Error"


    I think it's safe to say my lovely new Kemper is indeed, F****D

    This sort of error appeared very rarely for some people after software update. There isn't any general solution to it afaik, except contacting support. If you feel like fiddling with it, try to put release software (4.x) on USB stick and downgrade, but no guarantees it will do anything.

  • OK - so i tried all of the above, i've sent a support ticket too. I tried refreshing the whole thing, starting a new, this morning i received this message.


    "DSP Communication Error"


    I think it's safe to say my lovely new Kemper is indeed, F****D

    Yeah, I think it's safe to say that now! Unlucky, dude.
    On the bright side, there has been an instance or two of that meaning that the DSP card has come loose in its socket inside the machine. Should be a quick and easy fix, though you should probably demand a new one from the store you bought it from (Anderton's? Lol!), or contact Kemper to send you a replacement if you got it from them. I'm sure they'll do their utmost to rectify the situation, as they have done repeatedly, even if most of their customers don't have such a high profile and a position to influence future sales... ;)
    Hope you get it sorted swiftly. Just know that problems such as these are few and far between.