[Issue fixed in upcoming release!] Dear Kemper Devs and Mods is the morphing bug still on your to do list?

  • Title says it all. I'm still happy as ever with my KPA but I'm beginning to wonder whether this issue has been forgotten or simply relegated.

    As much as I have been enjoying the new features, I think it is a pity that known bugs such as these are not being addressed in a timely manner (issue has been known for over a year at least). Back when morphing was introduced it took me a while to figure out how to use it in a live situation. Once I did I invested quite an amount of time in optimizing my performances to make full use of what is a truly amazing feature. Unfortunately though, and despite the workaround that has been proposed, I find that morphing is just not reliable enough at the moment. BTW I'm talking here about the "double press" use of morphing, not the expression pedal-based one.


    So, just wanted to out the issue out there and ask the mods/devs for any feedback on the matter. It would be at least reassuring to know that a fix is coming soon ;)


    Best,


    David


    UPDATE: Issue has been addressed / fixed in the upcoming release :)

  • Sure. So, the issue is related to the morphing transitions when double pressing on the patch pedal. That is why you wouldn't have noted it if you use an expression pedal for morphing. The idea is that you can engage morphing after pressing on the selected patch pedal for a second time. To use it effectively, you can pre-program the speed of the transtitions (separateley, in fact, both when engaging or disengaging morphing). This allows in theory for smooth long transitions between sounds of effects settings. Unfortunately, due to the bug, double pressing will often just jump from one state to the next without "acknowledging" your transition settings. The issue is discussed more or less extensively in this thread here which was opened in march 2018. By that time, however, it was already a known problem to the community...


    BTW: This has not really been solved by any of the latest updates. I'm currently on the latest beta and the issue still persists...

  • This is the exact reason why I never bothered using morphing live, it's too much of a risk when using it with a stomp switch. Messing with expression pedals is not really my thing (apart from wah).

    ------


    Well, the benefits of Morphing are so great I think you are really missing the boat here. I would suggest to get a cheap (I use a Morley M2) expression pedal as the use is just too good for so many things; it can really simplify your performances or live stuff and so much more.



    I remmeber now about that issue with the rise and fall time etc. I think we're talking about with the button morphs. I have made those buttons reset the morph to default parameter it's much 'safer' for me with my clumsy feet.

  • Well, what can I say, I really agree with both of you. I also think the morphing feature is absolutely awesome and allows for amazing flexibility and nuance. The frustrating thing, however, is that after having worked perfectly for a long time, right now "double press" morphing is not really reliable and it just doesn't seem like something that would have to be so difficult to get fixed...

  • Well, the benefits of Morphing are so great I think you are really missing the boat here. I would suggest to get a cheap (I use a Morley M2) expression pedal as the use is just too good for so many things; it can really simplify your performances or live stuff and so much more.



    I remmeber now about that issue with the rise and fall time etc. I think we're talking about with the button morphs. I have made those buttons reset the morph to default parameter it's much 'safer' for me with my clumsy feet.

    I do use morphing right now, however I'm not using it to its full potential.


    I use a DIY MIDI pedal for switching performances. I have programmed it, so that when for instance slot 1 is engaged and I press the slot 1 button again, morphing is toggled. However, due to this bug, I find it risky to use with transition times longer than 0 seconds. Therefore, I only use the morph button to instantly switch an effect from 0% to 100% mix. This way I never have to mess with the code in the MIDI pedal and still have some flexibility in enabling/disabling different effects without switching rigs.


    Problem with expression pedals is that I can never get a smooth transition between two morph states.

  • What firmware are you on?

    Current Beta (new reverbs)


    I don’t have the problem

    tommyguitar can you be a bit more specific about this? So, are you using double-press to transition between morphing states and, if so, have you been using the method reliably and on a regular basis for long morphing transitions? It would be great news if it works for you actually, cause then a factory reset might fix it for me. But I'd rather not "tamper" with my setup right now since everything else is working as expected....

  • Agreed. It’s frustrating. I’ve owned Kemper for a year and love morphing and use it constantly but I have to work around this bug.


    Even worse, since updating to the new reverbs, all my REV slot morphs are just plain gone.


    I remember a mod saying that big was for sure fixed in the next release. It’s not.

  • Verminante

    Changed the title of the thread from “Dear Kemper Devs and Mods is the morphing bug still on your to do list?” to “[Issue fixed in upcoming release!] Dear Kemper Devs and Mods is the morphing bug still on your to do list?”.