SOLVED: MIDI Out Issue: Active Sensing

  • I've been using a 3 loop MIDI switcher to control 3 pedals with the Remote. It all functions properly, but there has always been a ticking sound that appears whenever at least one loop is engaged. The workaround has been to be super-quick with the volume pedal. But sometimes that doesn't suffice, and let's fact it - a workaround like this shouldn't be necessary.


    I've been working through this problem for the last 18 months. If I were to list all of the things I've done/tried/bought/sold/returned to troubleshoot this problem, we'll be here all day. I've tried it all and stumped more than a few techs with this one. Nothing other than unplugging the MIDI cable quiets the noise. Even a wireless MIDI connection passes the sound.


    The wireless MIDI connection passing the sound gave me one last idea. The KPA has to be sending signals, even when normal messages aren't.


    What I believe to be the source of this sound is the KPA's MIDI Out constantly sending what's called active sensing messages. If you don't know what that is - count yourself lucky. Its part of the MIDI specification that serves as a way to ask connected devices 'are you still there?'

    I've been told by Kemper Support that active sensing cannot be disabled in the KPA. I can't be 100% sure it's the culprit....because I can't disable it to check. But I've (literally) tried everything else I or anyone else I've spoken to can think of.


    Since I'm nearly out of ideas.... Is it possible to filter out these unneeded messages and prevent them from reaching the MIDI switcher? Or....is there some double-secret/super-user method of disabling active sensing in the KPA firmware?

  • Sorry, that you still didn't succeed to identify the trouble maker! Our support team has spent hours over the course of months to help you with this matter and point you in the right direction.


    Let me summarize a few facts:


    - The PROFILER MIDI engine is separated from audio via opto coupler as should. There can be no cross talk between MIDI and audio at the PROFILER side.

    - A wireless MIDI connection does also not pass any sound.

    - Active Sensing is in line with MIDI standards and used by many devices.

    - Active Sensing is sent at the MIDI OUT to support devices like Uno4Kemper. It is not sent at MIDI OUT nor MIDI THRU if these sockets are configured as outputs for sending MIDI PC#s from Performance Mode. And I guess that is what you do to control your loopers.

    - MIDI is used by thousands and no other user has reported clicking noise caused by MIDI. All PROFILER units send Active Sensing at their MIDI OUT by default in their as delivered state.

    - We have tested with two PROFILER units. Regardless, if Active Sensing is submitted or MIDI PC#s in Performance Mode, the receiving PROFILER device doesn't produce any ticking noise as expected.


    Please seriously investigate the receiving looper devices. These should also have effective opto couplers.

  • Wait.....if active sensing isn't supposed to be present when the OUT/Thru sockets are configured for PC#s in Performance mode, could that mean I've set them up incorrectly and active sensing is being sent when it doesn't have to be?

    How would I check this?

  • How would I check this?

    How about connecting your Kemper to a PC with a MIDI interface and using a tool like MidiOx to look at the output?


    And to filter out stuff like active sensing, you could use little MIDI filter boxes like the MIDI Solutions Event Processor or the miditech MidiThru/Filter. These are small self-contained programmable MIDI processors that you can put between your Kemper and the looper to filter out specific data.


    Cheers,


    Torsten

  • And again: the PROFILER sending Active Sensing is absolutely in line with MIDI standards. There is no PROFILER MIDI OUT issue.


    Your external devices are suspect producing noise when receiving MIDI comands. That is the real issue. Have you raised this flaw to their manufacturer? What did they say?

  • I've been using a 3 loop MIDI switcher to control 3 pedals with the Remote. It all functions properly, but there has always been a ticking sound that appears whenever at least one loop is engaged. The workaround has been to be super-quick with the volume pedal. But sometimes that doesn't suffice, and let's fact it - a workaround like this shouldn't be necessary.

    Sound like a grounding issue. Or a shielding issue. A bit like what you get when you put your mobile phone next to an amp. It doesn't have anything to do with the type of message that's transmitted (active sense, note or program change). It is caused by a component in your setup, eventually one with an electrical fault that results in the grounding/shielding issue.

    Get in touch with Profiler online support team here

  • I have never once suggested that Kemper isn't following the MIDI Specification. I'm sure you are adhering to it.


    - Active Sensing is sent at the MIDI OUT to support devices like Uno4Kemper. It is not sent at MIDI OUT nor MIDI THRU if these sockets are configured as outputs for sending MIDI PC#s from Performance Mode. And I guess that is what you do to control your loopers.

    Perhaps I'm mistaken, but I take this to mean that active sensing data should not be present in Performance Mode when sending PC#s.


    If this is accurate - that "it is not sent at MIDI OUT nor MIDI THRU if these sockets are configured as outputs for sending MIDI PC#s from Performance Mode" then I may have misconfigured something.


    In Performance Mode, active sensing is present. Thanks to ToH2002, I can provide two forms of evidence. You can also look at the video I sent Support a few days ago. The CME WIDI Master shows data coming from the MIDI OUT.


    I connected the MIDI OUT on my KPA to the MIDI IN on my audio interface and used MIDIPipe to view any MIDI activity. The screenshot below shows the result. Active sensing is present in Performance Mode and configured to send PC#s. Nothing else is being sent.


       


    I got ahold of a MIDI Solutions Merge, which per a conversation with them, does not pass active sensing to its outputs. The blue LED indicates MIDI data present at the Merge's MIDI IN.


    - Without the Merge in line, the active sensing click appears after a couple of minutes. It seems to take a bit of time for the noise to become audible. Previously, I thought I'd found a remedy, only to hear it a short time later.


    When I put the Merge in line, the sound is gone.


    - I swapped the Merge in and out half a dozen times. Quiet while in line, even after 20-30 minutes, and as much added gain as possible to bring out any little click. Nothing. Just the expected amp/pedal hiss associated with dirt pedals.


    - With the Merge removed and a direct line from the KPA to the switcher MIDI IN, the sound reappears within 5 minutes and becomes unmistakable, rendering this setup useless.


    The switchers I'm using are not the problem. I've used two different brands.


    Their designs are different, as are the continents of manufacture. Despite these differences, the issue is not only present but identical for both units. Even the delayed onset time I mentioned is consistent.


    With such different units, one would think there would be some differences. There isn't.


    And again: the PROFILER sending Active Sensing is absolutely in line with MIDI standards. There is no PROFILER MIDI OUT issue.

    Once again, I've never suggested that the MIDI spec isn't adhered to by Kemper. Kemper and the switcher manufacturers all state that they follow the published MIDI specification. Everything appears to be working within specs.


    That doesn't change the fact that active sensing is the root cause here. I believe I've proven that.


    I've been troubleshooting this gremlin for over 18 months. I first contacted Wampler pedals when I thought it was one of their devices causing problems. I have looked at wall power, power supplies, cable proximity, cable quality, and different switchers and came close to shipping my KPA off to British Audio to see if it was a hardware issue. I've spoken directly to several manufacturers about this.


    Each piece of this puzzle works as the manufacturer intended and is compliant with the relevant specifications.


    With that said:


    It makes no difference if everything is within spec or not. Nor does it matter how many others use these products with no issues. None of that changes the fact that active sensing is the culprit.


    The real problem seems to be that I am the only poor schlub dealing with this problem.


    The bottom line is:


    If I could disable active sensing in the KPA, which is unnecessary for my chosen application, the problem is solved.


    Numerous units allow you to turn active sensing on or off. You can easily find postings where people are having issues with active sensing. Perform a Google search for "active sensing midi" Of the ten initial returns I receive, the top 5 explain or define what it is. The second 5 all relate to people having issues with its presence, especially when it is unnecessary for the application.


    I have no animosity towards Kemper Support or the design choices made long ago. Your product works as intended.


    I am disappointed to have the solution in sight but denied the ability to implement it with the KPA.

    "Without music, life would be a mistake.” ― Friedrich Nietzsche


    Contact - Kemper Amps

    Edited once, last by Ruefus: duplicate image ().

  • We have been spending too much time and energy on this non-PROFILER issue. Checking out a quality signal looper like Lehle should be an effective short cut to a solution.

  • We have been spending too much time and energy on this non-PROFILER issue. Checking out a quality signal looper like Lehle should be an effective short cut to a solution.

    So active sensing *should* be active in Performance Mode when sending PC#s ? Yes or no?


    You've been spending too much time? Good grief. Sorry to be a bother.


    As for 'a quality switcher'. You've implied it in the past, but I never thought you'd say I'd bought crap gear publicly. What hubris.


    Up until now, I was quite happy with the way I'd been treated. I understood my issue is an outlier and that what I was asking was a long shot. I've even said so over the last 18 months.

    To be told that *you* were spending too much time on it? Then you turn around and casually insult my choice of gear?


    That's not right. I never expected that from anyone at Kemper. Least of all you Burkhard.

  • KEMPER colleagues have been supporting you on this matter and pointing you to an effective solution. This is going on since May! But we are running in circles since you want to see the PROFILER as root cause of this noise. Check out the wording of the title of this thread.


    Back to my earlier question: What about the receiving device(s)? Have you raised this flaw to their manufacturer? What did they say?

  • Yes. I have spoken to multiple manufacturers starting in July of 2021. They are all following the MIDI standard and their units are functioning as they expect.


    Check out the wording of the title of this thread.

    The title of my post was not supposed to be negative. I can see how you might think that. This post was (literally) a Hail Mary attempt to find a solution. I'm not blaming Kemper.


    As I said before, you made a decision for active sensing to be on all the time. As it happens, that choice is the source of the noise. Everything works as intended by their designers, but the Profiler and switcher don't play well together.


    It happens.


    I was asking (OK, begging) for a way to shut active sensing off. The answer came back as no.


    Refusing to give up, I also asked if there is a way to filter that signal? I managed to answer my own question (with some help from another member here) with a yes:


    MIDI Solutions' Merger doesn't pass active sensing through its output. I got one and problem solved.

    MIDI Solutions: Active Sensing


    If you would, please clarify this for me:


    Quote from Burkhard

    - Active Sensing is sent at the MIDI OUT to support devices like Uno4Kemper. It is not sent at MIDI OUT nor MIDI THRU if these sockets are configured as outputs for sending MIDI PC#s from Performance Mode. And I guess that is what you do to control your loopers.

    Does this mean that in Performance Mode, when sending PC#s, active sensing is supposed to be off?

    If so - I've been doing something wrong this entire time.

  • In any case active sensing is only sent via MIDI OUT as the bi-directional protocol is exclusively supported at the MIDI OUT in combination with the MIDI IN. Under no circumstances active sensing could be sent via MIDI THRU. If you select the MIDI THRU as your output for sending MIDI PC#s from Performance Mode to your external device, there can be no active sensing and your ticking noise must have another origin.

  • In any case active sensing is only sent via MIDI OUT as the bi-directional protocol is exclusively supported at the MIDI OUT in combination with the MIDI IN. Under no circumstances active sensing could be sent via MIDI THRU. If you select the MIDI THRU as your output for sending MIDI PC#s from Performance Mode to your external device, there can be no active sensing and your ticking noise must have another origin.

    Forgive me....but HOLY SHIT Burkhard !!

    I can't test it with the switcher, but through MIDIPipe I see that the Thru behaves as you say. Your weekend will start before I can confirm - but I'm close to 100% certain this will address my issue without any additional gear or changes!!!

    I'll confirm back once I'm certain, but I'd be shocked if it doesn't work.

  • FYI.....I can confirm that using the MIDI THRU, the sound is gone. If I unplug from the THRU and plug into OUT - the ticking appears immediately. When reversed, it is not there.


    Shut the front door.


    THANK YOU Burkhard and Kemper Support for putting up with my persistence.