Kemper Rig Manager not seeing Profiler - OSX

  • I updated to OS 10.13.5 yesterday, and Rig Manager, which was previously working just fine, now refuses to see my Profiler.

    Initially I was getting the "You need to allow the Rig Manager extension in Security and Privacy" with no option to do so.

    In another thread, someone mentioned deleting all files and reinstalling.

    I deleted the .kext out of /Library/Extensions, and now any time I try to reinstall, it doesn't add that extension back.


  • I am having the same issue, I'm on MAC latest OSX, not only does Rig Manager not see the Profiler, it also cause it to hang/freeze. As soon as I use the tuner the profiler freezes, only way to get it back is to disconnect from USB and power down / power on the Profiler again. It was working fine, then all of a sudden this problem started happening. I opened a ticket but am not having much luck.

    "Music makes the world a better place. Music doesn't lie. If there is something to be changed in this world, then it can only happen through music."

    Jimi Hendrix.

  • the latest version doesn't require a kernel extension anymore. you need to use 2.1.41 or later

  • I have upgraded to the newest RM and have the same issue.

    you have a different issue, look at the original poster - the new version of Rig Manager does not rely on a driver anymore and therefore macOS will not display this message again. please contact support through the form on our website.

  • I have the same issue just installed the latest os for the profiler and latest rig manager doesn’t work with it
    now 2.1.126 does not .141 though

    Tried all the different combos when booting up

    Uninstalled & reinstalled
    Looks like I’ll be using .126 rig manager with the latest profiler os

    I’m using a Mac Pro 5 1 with os 10.13.5

  • I have the same issue just installed the latest os for the profiler and latest rig manager doesn’t work with it
    now 2.1.126 does not .141 though

    we are investigating this issue. as it turns out, we cannot replicate it so please get in touch with support. we need to work on this with users facing this particular issue.

  • I am having the same issue with the latest version of everything, and the previous, as well.
    The Kemper unit ignores anything you do on Rig Manager, or perhaps Rig Manager is not seeing the Kemper.
    Either way...there is no communication between them at all.

  • just tried to install 2.1.141 with 5.5.2 on profiler doesn't work maybe driver issue there was a chage in the driver possibly it's flat out not communicating with the profiler it's all good i'll just use the older software for awhile plus im contemplating selling my profiler anyway

  • I am also having the same problem. Every thing was working fine until I installed the latest version of Rig Manager. Now RM doesn't see my KPA. I"m running RM version 2.1.41 on a MacBook Pro running Sierra 10.12.6. I wish I had seen these posts before I installed the latest version of RM.
    I have opened a support ticket and am keeping my fingers crossed that a fix will come soon,

  • Is there any way to download and install the previous version of RM? On the download page I can only find the latest version (2.1.41). I'm wondering if I uninstalled RM and then installed the previous version
    everything would work fine again.

  • I received a reply from Kemper about the
    kext file too. Unfortunately I can’t find that file on my MacBook. If I go to Library/Extensions I see 15 instances of .kext files but none of them are Kemper. I also don’t have the previous version of the RM software update so I can’t go that route either. I replied back to Kemper about not finding the .kext file so I’m still without RM.
    I did a search of the computer but no results for a Kemper .kext file. Very frustrating